lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 30 Dec 2022 13:53:01 +0200
From:   Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
To:     Bartosz Golaszewski <brgl@...ev.pl>
Cc:     Linus Walleij <linus.walleij@...aro.org>,
        Shubhrajyoti Datta <shubhrajyoti.datta@....com>,
        linux-gpio@...r.kernel.org, linux-kernel@...r.kernel.org,
        Bartosz Golaszewski <bartosz.golaszewski@...aro.org>
Subject: Re: [PATCH] gpio: pca9570: rename platform_data to chip_data

On Fri, Dec 30, 2022 at 11:00:44AM +0100, Bartosz Golaszewski wrote:
> From: Bartosz Golaszewski <bartosz.golaszewski@...aro.org>
> 
> By convention platform_data refers to structures passed to drivers by
> code that registers devices. When talking about model-specific data
> structures associated with OF compatibles, we usually call them chip_data.
> 
> In order to avoid confusion rename all mentions of platform_data to
> chip_data.

Fine by me,
Reviewed-by: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>

> Fixes: fbb19fe17eae ("gpio: pca9570: add slg7xl45106 support")
> Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@...aro.org>
> ---
>  drivers/gpio/gpio-pca9570.c | 24 ++++++++++++------------
>  1 file changed, 12 insertions(+), 12 deletions(-)
> 
> diff --git a/drivers/gpio/gpio-pca9570.c b/drivers/gpio/gpio-pca9570.c
> index 6c07a8811a7a..6a5a8e593ed5 100644
> --- a/drivers/gpio/gpio-pca9570.c
> +++ b/drivers/gpio/gpio-pca9570.c
> @@ -18,11 +18,11 @@
>  #define SLG7XL45106_GPO_REG	0xDB
>  
>  /**
> - * struct pca9570_platform_data - GPIO platformdata
> + * struct pca9570_chip_data - GPIO platformdata
>   * @ngpio: no of gpios
>   * @command: Command to be sent
>   */
> -struct pca9570_platform_data {
> +struct pca9570_chip_data {
>  	u16 ngpio;
>  	u32 command;
>  };
> @@ -36,7 +36,7 @@ struct pca9570_platform_data {
>   */
>  struct pca9570 {
>  	struct gpio_chip chip;
> -	const struct pca9570_platform_data *p_data;
> +	const struct pca9570_chip_data *chip_data;
>  	struct mutex lock;
>  	u8 out;
>  };
> @@ -46,8 +46,8 @@ static int pca9570_read(struct pca9570 *gpio, u8 *value)
>  	struct i2c_client *client = to_i2c_client(gpio->chip.parent);
>  	int ret;
>  
> -	if (gpio->p_data->command != 0)
> -		ret = i2c_smbus_read_byte_data(client, gpio->p_data->command);
> +	if (gpio->chip_data->command != 0)
> +		ret = i2c_smbus_read_byte_data(client, gpio->chip_data->command);
>  	else
>  		ret = i2c_smbus_read_byte(client);
>  
> @@ -62,8 +62,8 @@ static int pca9570_write(struct pca9570 *gpio, u8 value)
>  {
>  	struct i2c_client *client = to_i2c_client(gpio->chip.parent);
>  
> -	if (gpio->p_data->command != 0)
> -		return i2c_smbus_write_byte_data(client, gpio->p_data->command, value);
> +	if (gpio->chip_data->command != 0)
> +		return i2c_smbus_write_byte_data(client, gpio->chip_data->command, value);
>  
>  	return i2c_smbus_write_byte(client, value);
>  }
> @@ -127,8 +127,8 @@ static int pca9570_probe(struct i2c_client *client)
>  	gpio->chip.get = pca9570_get;
>  	gpio->chip.set = pca9570_set;
>  	gpio->chip.base = -1;
> -	gpio->p_data = device_get_match_data(&client->dev);
> -	gpio->chip.ngpio = gpio->p_data->ngpio;
> +	gpio->chip_data = device_get_match_data(&client->dev);
> +	gpio->chip.ngpio = gpio->chip_data->ngpio;
>  	gpio->chip.can_sleep = true;
>  
>  	mutex_init(&gpio->lock);
> @@ -141,15 +141,15 @@ static int pca9570_probe(struct i2c_client *client)
>  	return devm_gpiochip_add_data(&client->dev, &gpio->chip, gpio);
>  }
>  
> -static const struct pca9570_platform_data pca9570_gpio = {
> +static const struct pca9570_chip_data pca9570_gpio = {
>  	.ngpio = 4,
>  };
>  
> -static const struct pca9570_platform_data pca9571_gpio = {
> +static const struct pca9570_chip_data pca9571_gpio = {
>  	.ngpio = 8,
>  };
>  
> -static const struct pca9570_platform_data slg7xl45106_gpio = {
> +static const struct pca9570_chip_data slg7xl45106_gpio = {
>  	.ngpio = 8,
>  	.command = SLG7XL45106_GPO_REG,
>  };
> -- 
> 2.37.2
> 

-- 
With Best Regards,
Andy Shevchenko


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ