[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20230104084512.1855243-1-sai.krishna.potthuri@amd.com>
Date: Wed, 4 Jan 2023 14:15:10 +0530
From: Sai Krishna Potthuri <sai.krishna.potthuri@....com>
To: Rob Herring <robh+dt@...nel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@...aro.org>,
Michal Simek <michal.simek@...inx.com>,
Borislav Petkov <bp@...en8.de>,
Mauro Carvalho Chehab <mchehab@...nel.org>,
Tony Luck <tony.luck@...el.com>,
James Morse <james.morse@....com>,
"Robert Richter" <rric@...nel.org>
CC: <devicetree@...r.kernel.org>,
<linux-arm-kernel@...ts.infradead.org>,
<linux-kernel@...r.kernel.org>, <linux-edac@...r.kernel.org>,
<saikrishna12468@...il.com>, <git@....com>,
Sai Krishna Potthuri <sai.krishna.potthuri@....com>
Subject: [PATCH v7 0/2] EDAC: Add support for Xilinx ZynqMP OCM EDAC
Add dt-binding and driver for Xilinx ZynqMP OCM controller.
changes in v7:
-> 2/2 - Renamed the driver file name to zynqmp_edac.c.
-> 2/2 - Update the UE error injection logic to use string separator,
also removed the inject_cebitpos() or inject_uebitpos() and handled in the
top level inject functions.
-> 2/2 - Changed the name of the debugfs directory to "ocm" to make it
simple.
-> 2/2 - Fixed few more comments like update commit description, used
IS_ENABLED(CONFIG_EDAC_DEBUG) instead of #ifdef, removing "controller"
string, local variable ordering.
changes in v6:
-> 2/2 - Updated subject prefix and commit description.
-> 2/2 - Used Debugfs instead of sysfs for error injection and
placed the injection logic under CONFIG_EDAC_DEBUG.
-> 2/2 - Dropped zynqmp_ocm prefix for all static APIs and structures.
-> 2/2 - Fixed few more comments related to using caps for acronyms,
dealing error info, UE logic simplification, using BIT() definitions.
changes in v5:
-> 1/2, 2/2 - Added 'Co-developed-by' tag.
-> 2/2 - Updated the driver hep text to be more clear about the hardware
this driver is targeted.
-> 2/2 - Fixed the warning reported by kernel test robot.
changes in v4:
-> 2/2 - Replaced \n\r with \n.
changes in v3:
-> 1/2 - Moved the binding from edac to memory-controllers directory.
-> 1/2 - Changed the file name to match with the compatible.
-> 1/2 - Used additionalProperties instead of unevaluatedProperties.
-> 1/2 - Used macro instead of constant value.
changes in v2:
-> 1/2 - Used define for interrupt flag.
-> 1/2 - Updated the description and title.
-> 2/2 - Removed Kernel doc for probe and remove.
-> 2/2 - Used COMPILE_TEST, used wrapper for get and ioremap resource.
-> 2/2 - Fixed few comments related to static variable declaration
and print statements.
Sai Krishna Potthuri (1):
EDAC/zynqmp: Add EDAC support for Xilinx ZynqMP OCM
Shubhrajyoti Datta (1):
dt-bindings: edac: Add bindings for Xilinx ZynqMP OCM
.../xlnx,zynqmp-ocmc-1.0.yaml | 45 ++
MAINTAINERS | 7 +
drivers/edac/Kconfig | 9 +
drivers/edac/Makefile | 1 +
drivers/edac/zynqmp_edac.c | 465 ++++++++++++++++++
5 files changed, 527 insertions(+)
create mode 100644 Documentation/devicetree/bindings/memory-controllers/xlnx,zynqmp-ocmc-1.0.yaml
create mode 100644 drivers/edac/zynqmp_edac.c
--
2.25.1
Powered by blists - more mailing lists