[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <96a670f1-a4ae-e07a-d630-7fcfcda86917@redhat.com>
Date: Mon, 9 Jan 2023 19:35:12 +0800
From: Xiubo Li <xiubli@...hat.com>
To: SeongJae Park <sj@...nel.org>,
Andrew Morton <akpm@...ux-foundation.org>
Cc: willy@...radead.org, Ilya Dryomov <idryomov@...il.com>,
Jeff Layton <jlayton@...nel.org>, linux-mm@...ck.org,
ceph-devel@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 0/3] add folio_headpage() macro
Sorry I didn't see the [1/3] and [2/3] patches in my inbox, it seems you
didn't CCed the ceph-devel@ mail list.
Thanks
On 07/01/2023 01:40, SeongJae Park wrote:
> The standard idiom for getting head page of a given folio is
> '&folio->page'. It is efficient and safe even if the folio is NULL,
> because the offset of page field in folio is zero. However, it makes
> the code not that easy to understand at the first glance, especially the
> NULL safety. Also, sometimes people forget the idiom and use
> 'folio_page(folio, 0)' instead. To make it easier to read and remember,
> add a new macro function called 'folio_headpage()' with the NULL case
> explanation. Then, replace the 'folio_page(folio, 0)' calls with
> 'folio_headpage(folio)'.
>
>
> SeongJae Park (3):
> include/linux/page-flags: add folio_headpage()
> mm: use folio_headpage() instead of folio_page()
> fs/ceph/addr: use folio_headpage() instead of folio_page()
>
> fs/ceph/addr.c | 2 +-
> include/linux/page-flags.h | 8 ++++++++
> mm/shmem.c | 4 ++--
> mm/slab.c | 6 +++---
> mm/slab_common.c | 4 ++--
> mm/slub.c | 4 ++--
> 6 files changed, 18 insertions(+), 10 deletions(-)
>
--
Best Regards,
Xiubo Li (李秀波)
Email: xiubli@...hat.com/xiubli@....com
Slack: @Xiubo Li
Powered by blists - more mailing lists