[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <d2c6f43a-e166-a201-4662-ba726347f2da@linux.intel.com>
Date: Fri, 13 Jan 2023 11:22:30 +0100
From: Amadeusz Sławiński
<amadeuszx.slawinski@...ux.intel.com>
To: Bard Liao <yung-chuan.liao@...ux.intel.com>,
alsa-devel@...a-project.org, vkoul@...nel.org
Cc: pierre-louis.bossart@...ux.intel.com, vinod.koul@...aro.org,
bard.liao@...el.com, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 1/5] soundwire: stream: uniquify dev_err() logs
On 1/13/2023 10:35 AM, Bard Liao wrote:
> From: Pierre-Louis Bossart <pierre-louis.bossart@...ux.intel.com>
>
> There are a couple of duplicate logs which makes harder than needed to
> follow the error flows. Add __func__ or make the log unique.
>
> Signed-off-by: Pierre-Louis Bossart <pierre-louis.bossart@...ux.intel.com>
> Reviewed-by: Ranjani Sridharan <ranjani.sridharan@...ux.intel.com>
> Signed-off-by: Bard Liao <yung-chuan.liao@...ux.intel.com>
> ---
> drivers/soundwire/stream.c | 14 ++++++++------
> 1 file changed, 8 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/soundwire/stream.c b/drivers/soundwire/stream.c
> index df3b36670df4..e0eae0b98267 100644
> --- a/drivers/soundwire/stream.c
> +++ b/drivers/soundwire/stream.c
> @@ -1389,7 +1389,7 @@ static int _sdw_prepare_stream(struct sdw_stream_runtime *stream,
>
> ret = do_bank_switch(stream);
> if (ret < 0) {
> - dev_err(bus->dev, "Bank switch failed: %d\n", ret);
> + dev_err(bus->dev, "do_bank_switch failed: %d\n", ret);
> goto restore_params;
> }
This one seems bit unrelated to the change and makes error message
inconsistent with:
https://git.kernel.org/pub/scm/linux/kernel/git/vkoul/soundwire.git/tree/drivers/soundwire/stream.c?h=next&id=545c365185a47672b1d5cc13c84057a1e874993c#n1498
and
https://git.kernel.org/pub/scm/linux/kernel/git/vkoul/soundwire.git/tree/drivers/soundwire/stream.c?h=next&id=545c365185a47672b1d5cc13c84057a1e874993c#n1575
which actually brings me to another suggestion, can this error message
perhaps be just moved into do_bank_switch() function itself, instead of
being duplicated multiple times or alternatively just also prefix all of
them with function name?
Powered by blists - more mailing lists