lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <0e0c90a2-d12c-f965-9cce-ecd5d28c09dd@redhat.com>
Date:   Wed, 18 Jan 2023 15:03:38 +0100
From:   David Hildenbrand <david@...hat.com>
To:     yang.yang29@....com.cn, akpm@...ux-foundation.org
Cc:     imbrenda@...ux.ibm.com, jiang.xuexin@....com.cn,
        linux-kernel@...r.kernel.org, linux-mm@...ck.org,
        ran.xiaokai@....com.cn, xu.xin.sc@...il.com, xu.xin16@....com.cn
Subject: Re: [PATCH v5 1/6] ksm: abstract the function
 try_to_get_old_rmap_item

On 30.12.22 02:12, yang.yang29@....com.cn wrote:
> From: xu xin <xu.xin16@....com.cn>
> 
> A new function try_to_get_old_rmap_item is abstracted from
> get_next_rmap_item. This function will be reused by the subsequent
> patches about counting ksm_zero_pages.
> 
> The patch improves the readability and reusability of KSM code.
> 
> Signed-off-by: xu xin <xu.xin16@....com.cn>
> Cc: David Hildenbrand <david@...hat.com>
> Cc: Claudio Imbrenda <imbrenda@...ux.ibm.com>
> Cc: Xuexin Jiang <jiang.xuexin@....com.cn>
> Reviewed-by: Xiaokai Ran <ran.xiaokai@....com.cn>
> Reviewed-by: Yang Yang <yang.yang29@....com.cn>
> ---
>   mm/ksm.c | 25 +++++++++++++++++++------
>   1 file changed, 19 insertions(+), 6 deletions(-)
> 
> diff --git a/mm/ksm.c b/mm/ksm.c
> index 83e2f74ae7da..5b0a7343ff4a 100644
> --- a/mm/ksm.c
> +++ b/mm/ksm.c
> @@ -2214,23 +2214,36 @@ static void cmp_and_merge_page(struct page *page, struct ksm_rmap_item *rmap_ite
>   	}
>   }
> 
> -static struct ksm_rmap_item *get_next_rmap_item(struct ksm_mm_slot *mm_slot,
> -					    struct ksm_rmap_item **rmap_list,
> -					    unsigned long addr)
> +static struct ksm_rmap_item *try_to_get_old_rmap_item(unsigned long addr,
> +					 struct ksm_rmap_item **rmap_list)
>   {
> -	struct ksm_rmap_item *rmap_item;
> -
>   	while (*rmap_list) {
> -		rmap_item = *rmap_list;
> +		struct ksm_rmap_item *rmap_item = *rmap_list;

Empty line missing.

>   		if ((rmap_item->address & PAGE_MASK) == addr)
>   			return rmap_item;
>   		if (rmap_item->address > addr)
>   			break;
>   		*rmap_list = rmap_item->rmap_list;
> +		/* Running here indicates it's vma has been UNMERGEABLE */

"If we end up here, the VMA is UNMERGEABLE."

Although I am not sure if that is true?

>   		remove_rmap_item_from_tree(rmap_item);
>   		free_rmap_item(rmap_item);
>   	}
> 
> +	return NULL;
> +}
> +
> +static struct ksm_rmap_item *get_next_rmap_item(struct ksm_mm_slot *mm_slot,
> +					    struct ksm_rmap_item **rmap_list,
> +					    unsigned long addr)
> +{
> +	struct ksm_rmap_item *rmap_item;
> +
> +	/* lookup if we have a old rmap_item matching the addr*/

I suggest dropping that comment, "try_to_get_old_rmap_item()" is 
expressive enough.

> +	rmap_item = try_to_get_old_rmap_item(addr, rmap_list);
> +	if (rmap_item)
> +		return rmap_item;
> +
> +	/* Need to allocate a new rmap_item */

I suggest dropping that comment for the same reason.

>   	rmap_item = alloc_rmap_item();
>   	if (rmap_item) {
>   		/* It has already been zeroed */

-- 
Thanks,

David / dhildenb

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ