[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20230123135913.2720991-1-astrid.rost@axis.com>
Date: Mon, 23 Jan 2023 14:59:10 +0100
From: Astrid Rost <astrid.rost@...s.com>
To: Mark Brown <broonie@...nel.org>,
Liam Girdwood <lgirdwood@...il.com>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@...aro.org>
CC: <kernel@...s.com>, <alsa-devel@...a-project.org>,
<linux-kernel@...r.kernel.org>, Astrid Rost <astrid.rost@...s.com>
Subject: [PATCH v3 0/3] ASoC: simple-card-utils: create jack inputs for aux_devs
Add a generic way to create jack inputs for auxiliary jack detection
drivers (e.g. via i2c, spi), which are not part of any real codec.
The simple-card can be used as combining card driver to add the jacks,
no new one is required.
Create a jack (for input-events) for jack devices in the auxiliary
device list (aux_devs). A device which returns a valid value on
get_jack_type counts as jack device; set_jack is required
to add the jack to the device.
v1 -> v2: Auxiliary jack drivers return the correct snd_jack_type with
the function: get_jack_type.
- No devicetree changes in simple-card.
- soc-component: changed name to: get_jack_type.
- simple-jack-utils: updated algorithm to add jack devices.
A device which returns a valid value on get_jack_type counts as jack
device
- ts3a227e: added devicetree property jack-type, added NULL check for jack.
v2 -> v3: ts3a227e: remove devictree property.
Astrid Rost (3):
[PATCH v3 1/3] ASoC: soc-component: add get_jack_type
[PATCH v3 2/3] ASoC: simple-card-utils: create jack inputs for aux_devs
[PATCH v3 3/3] ASoC: ts3a227e: add set_jack and get_jack_type
include/sound/simple_card_utils.h | 3 ++
include/sound/soc-component.h | 2 ++
sound/soc/codecs/ts3a227e.c | 20 ++++++++++-
sound/soc/generic/simple-card-utils.c | 49 +++++++++++++++++++++++++++
sound/soc/generic/simple-card.c | 4 +++
sound/soc/soc-component.c | 20 +++++++++++
6 files changed, 97 insertions(+), 1 deletion(-)
--
2.30.2
Powered by blists - more mailing lists