[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <e2de778d-50f8-ed12-208f-4b21d2099eda@nvidia.com>
Date: Mon, 23 Jan 2023 19:03:24 -0800
From: John Hubbard <jhubbard@...dia.com>
To: David Howells <dhowells@...hat.com>,
Al Viro <viro@...iv.linux.org.uk>,
Christoph Hellwig <hch@...radead.org>,
Jason Gunthorpe <jgg@...dia.com>
CC: Matthew Wilcox <willy@...radead.org>, Jens Axboe <axboe@...nel.dk>,
"Jan Kara" <jack@...e.cz>, Jeff Layton <jlayton@...nel.org>,
Logan Gunthorpe <logang@...tatee.com>,
<linux-fsdevel@...r.kernel.org>, <linux-block@...r.kernel.org>,
<linux-kernel@...r.kernel.org>, "Christoph Hellwig" <hch@....de>,
<linux-mm@...ck.org>
Subject: Re: [PATCH v8 03/10] mm: Provide a helper to drop a pin/ref on a page
On 1/23/23 09:30, David Howells wrote:
> Provide a helper in the get_user_pages code to drop a pin or a ref on a
> page based on being given FOLL_GET or FOLL_PIN in its flags argument or do
> nothing if neither is set.
>
> Signed-off-by: David Howells <dhowells@...hat.com>
> cc: Al Viro <viro@...iv.linux.org.uk>
> cc: Christoph Hellwig <hch@....de>
> cc: Matthew Wilcox <willy@...radead.org>
> cc: linux-fsdevel@...r.kernel.org
> cc: linux-block@...r.kernel.org
> cc: linux-mm@...ck.org
> ---
> include/linux/mm.h | 3 +++
> mm/gup.c | 22 ++++++++++++++++++++++
> 2 files changed, 25 insertions(+)
>
> diff --git a/include/linux/mm.h b/include/linux/mm.h
> index 8f857163ac89..3de9d88f8524 100644
> --- a/include/linux/mm.h
> +++ b/include/linux/mm.h
> @@ -1367,6 +1367,9 @@ static inline bool is_cow_mapping(vm_flags_t flags)
> #define SECTION_IN_PAGE_FLAGS
> #endif
>
> +void folio_put_unpin(struct folio *folio, unsigned int flags);
> +void page_put_unpin(struct page *page, unsigned int flags);
How about these names instead:
folio_put_or_unpin()
page_put_or_unpin()
?
Also, could we please change the name of the flags argument, to
gup_flags?
> +
> /*
> * The identification function is mainly used by the buddy allocator for
> * determining if two pages could be buddies. We are not really identifying
> diff --git a/mm/gup.c b/mm/gup.c
> index f45a3a5be53a..3ee4b4c7e0cb 100644
> --- a/mm/gup.c
> +++ b/mm/gup.c
> @@ -191,6 +191,28 @@ static void gup_put_folio(struct folio *folio, int refs, unsigned int flags)
> folio_put_refs(folio, refs);
> }
>
> +/**
> + * folio_put_unpin - Unpin/put a folio as appropriate
> + * @folio: The folio to release
> + * @flags: gup flags indicating the mode of release (FOLL_*)
> + *
> + * Release a folio according to the flags. If FOLL_GET is set, the folio has a
> + * ref dropped; if FOLL_PIN is set, it is unpinned; otherwise it is left
> + * unaltered.
> + */
> +void folio_put_unpin(struct folio *folio, unsigned int flags)
> +{
> + if (flags & (FOLL_GET | FOLL_PIN))
Another minor complication is that FOLL_PIN is supposed to be an
internal-to-mm flag. But here (and in another part of the series), it
has leaked into the public API. One approach would be to give up and
just admit that, like FOLL_GET, FOLL_PIN has escaped into the wild.
Another approach would be to use a new set of flags, such as
USE_FOLL_GET and USE_FOLL_PIN.
But I'm starting to lean toward the first approach: just let FOLL_PIN be
used in this way, treat it as part of the external API at least for this
area (not for gup/pup calls, though).
So after all that thinking out loud, I think this is OK to use FOLL_PIN.
+Cc Jason Gunthorpe, because he is about to split up FOLL_* into public
and internal sets.
thanks,
--
John Hubbard
NVIDIA
Powered by blists - more mailing lists