lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 27 Jan 2023 11:18:50 -0500
From:   Guillaume Ranquet <granquet@...libre.com>
To:     CK Hu <ck.hu@...iatek.com>, Vinod Koul <vkoul@...nel.org>,
        Jitao shi <jitao.shi@...iatek.com>,
        Kishon Vijay Abraham I <kishon@...com>,
        Daniel Vetter <daniel@...ll.ch>,
        Matthias Brugger <matthias.bgg@...il.com>,
        Chunfeng Yun <chunfeng.yun@...iatek.com>,
        Chun-Kuang Hu <chunkuang.hu@...nel.org>,
        Krzysztof Kozlowski <krzysztof.kozlowski+dt@...aro.org>,
        David Airlie <airlied@...il.com>,
        Philipp Zabel <p.zabel@...gutronix.de>,
        Rob Herring <robh+dt@...nel.org>
Cc:     linux-mediatek@...ts.infradead.org,
        linux-arm-kernel@...ts.infradead.org, linux-kernel@...r.kernel.org,
        mac.shen@...iatek.com,
        Krzysztof Kozlowski <krzysztof.kozlowski@...aro.org>,
        linux-phy@...ts.infradead.org,
        Guillaume Ranquet <granquet@...libre.com>,
        devicetree@...r.kernel.org,
        AngeloGioacchino Del Regno 
        <angelogioacchino.delregno@...labora.com>, stuart.lee@...iatek.com
Subject: Re: [PATCH v5 0/3] Add MT8195 HDMI phy support

On Fri, 27 Jan 2023 16:55, Guillaume Ranquet <granquet@...libre.com> wrote:
>Add support for HDMI phy on MT8195.
>

Please disregard this, as I meant to send v6 and not a new v5...
link to the actual v6 is here:
https://lore.kernel.org/linux-mediatek/20220919-v6-0-2f641c422cb6@baylibre.com/

Sorry for spamming your inboxes,
Guillaume.

>This is split from the previous v3 to contain only the phy related
>changes to the HDMI support for mt8195 as suggested by Vinod.
>
>This is based on top of next-20221121
>
>To: Chunfeng Yun <chunfeng.yun@...iatek.com>
>To: Kishon Vijay Abraham I <kishon@...com>
>To: Vinod Koul <vkoul@...nel.org>
>To: Rob Herring <robh+dt@...nel.org>
>To: Krzysztof Kozlowski <krzysztof.kozlowski+dt@...aro.org>
>To: Matthias Brugger <matthias.bgg@...il.com>
>To: Chun-Kuang Hu <chunkuang.hu@...nel.org>
>To: Philipp Zabel <p.zabel@...gutronix.de>
>To: David Airlie <airlied@...il.com>
>To: Daniel Vetter <daniel@...ll.ch>
>To: CK Hu <ck.hu@...iatek.com>
>To: Jitao shi <jitao.shi@...iatek.com>
>Cc: linux-arm-kernel@...ts.infradead.org
>Cc: linux-mediatek@...ts.infradead.org
>Cc: linux-phy@...ts.infradead.org
>Cc: devicetree@...r.kernel.org
>Cc: linux-kernel@...r.kernel.org
>Cc: Krzysztof Kozlowski <krzysztof.kozlowski@...aro.org>
>Cc: AngeloGioacchino Del Regno <angelogioacchino.delregno@...labora.com>
>Cc: mac.shen@...iatek.com
>CC: stuart.lee@...iatek.com
>Signed-off-by: Guillaume Ranquet <granquet@...libre.com>
>---
>Changes in v5:
>- Adapt clock bit ratio when TMDS is over 340M
>- Used sized integers for register read/writes
>- Removed useless comments
>- Shortened function names
>- Link to v4: https://lore.kernel.org/r/20220919-v4-0-bdc21e1307e9@baylibre.com
>
>Changes in v4:
>- Dedicated series for HDMI phy support (without the drm/ related
>  changes)
>- Removed useless variable initializations in phy driver
>- Link to v3: https://lore.kernel.org/r/20220919-v3-0-a803f2660127@baylibre.com
>
>Changes in v3:
>- phy: Grouped register and bit definition together to add clarity
>- dt-bindings: Addressed comments
>- Link to v2: https://lore.kernel.org/r/20220919-v2-0-8419dcf4f09d@baylibre.com
>
>Changes in v2:
>- Removed syscon requirement from the hdmi node
>- Use as much as possible bit FIELD_PREP/FIELD_GET macros across all the
>  patches
>- Make cec optional dynamically instead of hardcoded with a flag
>- Renamed hdmi variants to v1 (legacy) and v2 (mt8195) while waiting for
>  a better name
>- Rework hdmi v2 code to use a connector (same as v1)
>- Remove "magic" 0x43 addr special handling in hdmi ddc code
>- Link to v1: https://lore.kernel.org/r/20220919-v1-0-4844816c9808@baylibre.com
>
>---
>Guillaume Ranquet (3):
>      dt-bindings: phy: mediatek: hdmi-phy: Add mt8195 compatible
>      phy: phy-mtk-hdmi: Add generic phy configure callback
>      phy: mediatek: add support for phy-mtk-hdmi-mt8195
>
> .../devicetree/bindings/phy/mediatek,hdmi-phy.yaml |   1 +
> drivers/phy/mediatek/Makefile                      |   1 +
> drivers/phy/mediatek/phy-mtk-hdmi-mt8195.c         | 523 +++++++++++++++++++++
> drivers/phy/mediatek/phy-mtk-hdmi-mt8195.h         | 111 +++++
> drivers/phy/mediatek/phy-mtk-hdmi.c                |  15 +
> drivers/phy/mediatek/phy-mtk-hdmi.h                |   3 +
> 6 files changed, 654 insertions(+)
>---
>base-commit: e2f86c02fdc96ca29ced53221a3cbf50aa6f8b49
>change-id: 20220919-hdmi_mtk
>
>Best regards,
>--
>Guillaume Ranquet <granquet@...libre.com>

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ