[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAHk-=wjF6j264jDFcY3wgzOUA2RL2SpD2oL5BF9JqCkz3A413Q@mail.gmail.com>
Date: Thu, 2 Feb 2023 16:19:57 -0800
From: Linus Torvalds <torvalds@...ux-foundation.org>
To: Mike Christie <michael.christie@...cle.com>
Cc: hch@...radead.org, stefanha@...hat.com, jasowang@...hat.com,
mst@...hat.com, sgarzare@...hat.com,
virtualization@...ts.linux-foundation.org, brauner@...nel.org,
ebiederm@...ssion.com, konrad.wilk@...cle.com,
linux-kernel@...r.kernel.org, Christoph Hellwig <hch@....de>
Subject: Re: [PATCH v11 4/8] fork: Add USER_WORKER flag to ignore signals
On Thu, Feb 2, 2023 at 3:25 PM Mike Christie
<michael.christie@...cle.com> wrote:
>
> + if (args->worker_flags & USER_WORKER_SIG_IGN)
> + ignore_signals(p);
Same comment as for the other case.
There are real reasons to avoid bitfields:
- you can't pass addresses to them around
- it's easier to read or assign multiple fields in one go
- they are horrible for ABI issues due to the exact bit ordering and
padding being very subtle
but none of those issues are relevant here, where it's a kernel-internal ABI.
All these use-cases seem to actually be testing one bit at a time, and
the "assignments" are structure initializers for which named bitfields
are actually perfect and just make the initializer more legible.
Linus
Powered by blists - more mailing lists