[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20230205183424.xwt54mlyixxgkhl6@offworld>
Date: Sun, 5 Feb 2023 10:34:24 -0800
From: Davidlohr Bueso <dave@...olabs.net>
To: John Stultz <jstultz@...gle.com>
Cc: LKML <linux-kernel@...r.kernel.org>,
"Paul E. McKenney" <paulmck@...nel.org>,
Josh Triplett <josh@...htriplett.org>,
Joel Fernandes <joel@...lfernandes.org>,
Juri Lelli <juri.lelli@...hat.com>,
Valentin Schneider <vschneid@...hat.com>,
Dietmar Eggemann <dietmar.eggemann@....com>
Subject: Re: [PATCH v2 1/4] locktorture: Add nested_[un]lock() hooks and
nlocks parameter
On Fri, 03 Feb 2023, John Stultz wrote:
>In order ot extend locktorture to support lock nesting, add
^ to
>nested_lock() and nested_unlock() hooks to the torture ops.
>
>These take a 32bit lockset mask which is generated at random,
>so some number of locks will be taken before the main lock is
>taken and released afterwards.
>
>Additionally, add nlocks module parameter to allow specifying
>the number of nested locks to be used.
>
>This has been helpful to uncover issues in the proxy-exec
>series development.
>
>This was inspired by locktorture extensions originally implemented
>by Connor O'Brien, for stress testing the proxy-execution series:
> https://lore.kernel.org/lkml/20221003214501.2050087-12-connoro@google.com/
>
>Comments or feedback would be greatly appreciated!
Both of the above statements should be in a cover letter patch.
>
>Cc: Davidlohr Bueso <dave@...olabs.net>
>Cc: "Paul E. McKenney" <paulmck@...nel.org>
>Cc: Josh Triplett <josh@...htriplett.org>
>Cc: Joel Fernandes <joel@...lfernandes.org>
>Cc: Juri Lelli <juri.lelli@...hat.com>
>Cc: Valentin Schneider <vschneid@...hat.com>
>Cc: Dietmar Eggemann <dietmar.eggemann@....com>
>Signed-off-by: John Stultz <jstultz@...gle.com>
Reviewed-by: Davidlohr Bueso <dave@...olabs.net>
With some small nits below.
>---
> kernel/locking/locktorture.c | 23 +++++++++++++++++++----
> 1 file changed, 19 insertions(+), 4 deletions(-)
>
>diff --git a/kernel/locking/locktorture.c b/kernel/locking/locktorture.c
>index 9c2fb613a55d..f4fbd3194654 100644
>--- a/kernel/locking/locktorture.c
>+++ b/kernel/locking/locktorture.c
>@@ -48,6 +48,9 @@ torture_param(int, stat_interval, 60,
> torture_param(int, stutter, 5, "Number of jiffies to run/halt test, 0=disable");
> torture_param(int, verbose, 1,
> "Enable verbose debugging printk()s");
>+torture_param(int, nlocks, 0, "Number of nested locks");
Maybe rename the parameter to 'nested_locks'? It would also be good to
inform the 8 limit. "Number of nested locks (max = 8)".
Powered by blists - more mailing lists