lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 7 Feb 2023 13:21:54 +0200
From:   Iuliana Prodan <iuliana.prodan@....com>
To:     Shengjiu Wang <shengjiu.wang@....com>, nicoleotsuka@...il.com,
        Xiubo.Lee@...il.com, festevam@...il.com, shengjiu.wang@...il.com,
        lgirdwood@...il.com, broonie@...nel.org, perex@...ex.cz,
        tiwai@...e.com, alsa-devel@...a-project.org
Cc:     linuxppc-dev@...ts.ozlabs.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] ASoC: fsl_sai: fix getting version from VERID

On 2/7/2023 11:04 AM, Shengjiu Wang wrote:
> The version information is at the bit31 ~ bit16 in the VERID
> register, so need to right shift 16bit to get it, otherwise
> the result of comparison "sai->verid.version >= 0x0301" is
> wrong.
>
> Fixes: 99c1e74f25d4 ("ASoC: fsl_sai: store full version instead of major/minor")
> Signed-off-by: Shengjiu Wang <shengjiu.wang@....com>
> ---
>   sound/soc/fsl/fsl_sai.c | 1 +
>   1 file changed, 1 insertion(+)
>
> diff --git a/sound/soc/fsl/fsl_sai.c b/sound/soc/fsl/fsl_sai.c
> index c365afd6c4ea..1b197478b3d9 100644
> --- a/sound/soc/fsl/fsl_sai.c
> +++ b/sound/soc/fsl/fsl_sai.c
> @@ -1142,6 +1142,7 @@ static int fsl_sai_check_version(struct device *dev)
>   
>   	sai->verid.version = val &
>   		(FSL_SAI_VERID_MAJOR_MASK | FSL_SAI_VERID_MINOR_MASK);
> +	sai->verid.version >>= FSL_SAI_VERID_MINOR_SHIFT;
>   	sai->verid.feature = val & FSL_SAI_VERID_FEATURE_MASK;
>   
>   	ret = regmap_read(sai->regmap, FSL_SAI_PARAM, &val);


I would put the version in one line, but probably is easier to read this 
way.
Also, please explain, in commit message, what and from where is 0x0301 - 
might worth adding a macro for this, in another commit, of course.
Otherwise,

Reviewed-by: Iuliana Prodan <iuliana.prodan@....com>

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ