[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <Y+QM9zQyJfSgzc7R@spud>
Date: Wed, 8 Feb 2023 20:58:31 +0000
From: Conor Dooley <conor@...nel.org>
To: Sunil V L <sunilvl@...tanamicro.com>
Cc: Palmer Dabbelt <palmer@...belt.com>,
Albert Ou <aou@...s.berkeley.edu>,
"Rafael J . Wysocki" <rafael@...nel.org>,
Len Brown <lenb@...nel.org>,
Thomas Gleixner <tglx@...utronix.de>,
Marc Zyngier <maz@...nel.org>,
Daniel Lezcano <daniel.lezcano@...aro.org>,
Jonathan Corbet <corbet@....net>,
linux-riscv@...ts.infradead.org, linux-acpi@...r.kernel.org,
linux-kernel@...r.kernel.org, linux-doc@...r.kernel.org,
Anup Patel <apatel@...tanamicro.com>,
Andrew Jones <ajones@...tanamicro.com>,
Atish Patra <atishp@...osinc.com>
Subject: Re: [PATCH 05/24] RISC-V: ACPI: Add basic functions to build ACPI
core
On Mon, Jan 30, 2023 at 11:52:06PM +0530, Sunil V L wrote:
> Introduce acpi.c and its related header files to provide
> fundamental needs of extern variables and functions for ACPI core.
> - asm/acpi.h for arch specific variables and functions needed by
> ACPI driver core;
> - acpi.c - Add function to initialize ACPI tables.
> - acpi.c for RISC-V related ACPI implementation for ACPI driver
> core;
>
> Code is mostly leveraged from ARM64.
> diff --git a/arch/riscv/kernel/acpi.c b/arch/riscv/kernel/acpi.c
> + * __acpi_map_table() will be called before page_init(), so early_ioremap()
rg "\bpage_init\("
arch/riscv/kernel/acpi.c
54: * __acpi_map_table() will be called before page_init(), so early_ioremap()
arch/arm64/kernel/acpi.c
86: * __acpi_map_table() will be called before page_init(), so early_ioremap()
This function doesn't appear to exist, perhaps what you are looking for is
paging_init()?
> + * or early_memremap() should be called here to for ACPI table mapping.
> + */
> +void __init __iomem *__acpi_map_table(unsigned long phys, unsigned long size)
> +{
> + if (!size)
> + return NULL;
> +
> + return early_memremap(phys, size);
> +}
> +void __init acpi_boot_table_init(void)
> +{
> + /*
> + * Enable ACPI instead of device tree unless
> + * - ACPI has been disabled explicitly (acpi=off), or
> + * - firmware has not populated ACPI ptr in EFI system table
> + */
> +
> + if (param_acpi_off || (efi.acpi20 == EFI_INVALID_TABLE_ADDR))
There's an extraneous set of () around the second item here.
> + goto done;
> + /*
A small nit: a newline before opening the comment block here please!
Download attachment "signature.asc" of type "application/pgp-signature" (229 bytes)
Powered by blists - more mailing lists