lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Wed, 8 Feb 2023 06:48:11 +0100
From:   Jiri Slaby <jirislaby@...nel.org>
To:     George Kennedy <george.kennedy@...cle.com>,
        gregkh@...uxfoundation.org, torvalds@...ux-foundation.org
Cc:     sfr@...b.auug.org.au, akpm@...ux-foundation.org,
        linux-kernel@...r.kernel.org, linux-serial@...r.kernel.org
Subject: Re: [PATCH v2] vc_screen: break from vcs_read() while loop if
 vcs_vc() returns NULL

On 07. 02. 23, 13:48, George Kennedy wrote:
> If vcs_vc() returns NULL in vcs_read(), break from while loop if partial
> read, else if no reads have been done, go to unlock_out and return -ENXIO.
> In addition, change the goto unlock_out after vcs_size() to a break
> to conform to the break handling after vcs_vc().
> 
> Fixes: ac751efa6a0d ("console: rename acquire/release_console_sem() to console_lock/unlock()")
> Reported-by: Linus Torvalds <torvalds@...ux-foundation.org>
> Suggested-by: Linus Torvalds <torvalds@...ux-foundation.org>
> Signed-off-by: George Kennedy <george.kennedy@...cle.com>
> ---
>   drivers/tty/vt/vc_screen.c | 14 ++++++--------
>   1 file changed, 6 insertions(+), 8 deletions(-)
> 
> diff --git a/drivers/tty/vt/vc_screen.c b/drivers/tty/vt/vc_screen.c
> index f566eb1839dc..c599b452969f 100644
> --- a/drivers/tty/vt/vc_screen.c
> +++ b/drivers/tty/vt/vc_screen.c
> @@ -406,19 +406,17 @@ vcs_read(struct file *file, char __user *buf, size_t count, loff_t *ppos)
>   		ret = -ENXIO;
>   		vc = vcs_vc(inode, &viewed);
>   		if (!vc)
> -			goto unlock_out;
> +			break;
>   
>   		/* Check whether we are above size each round,
>   		 * as copy_to_user at the end of this loop
>   		 * could sleep.
>   		 */
> -		size = vcs_size(vc, attr, uni_mode);
> -		if (size < 0) {
> -			if (read)
> -				break;
> -			ret = size;
> -			goto unlock_out;
> -		}
> +		ret = vcs_size(vc, attr, uni_mode);
> +		if (ret < 0)
> +			break;
> +		size = ret;
> +		ret = 0;

I think the previous "size = vcs_size()" and "ret = size" in the error 
path looked better than this "size = ret" and "ret = 0" here. I mean why 
not to preserve:

	size = vcs_size(vc, attr, uni_mode);
	if (size < 0) {
		ret = size;
		break;
	}

?

thanks,
-- 
js
suse labs

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ