lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 14 Feb 2023 00:02:22 +0000
From:   "Huang, Kai" <kai.huang@...el.com>
To:     "kvm@...r.kernel.org" <kvm@...r.kernel.org>,
        "Hansen, Dave" <dave.hansen@...el.com>,
        "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
CC:     "Luck, Tony" <tony.luck@...el.com>,
        "david@...hat.com" <david@...hat.com>,
        "bagasdotme@...il.com" <bagasdotme@...il.com>,
        "ak@...ux.intel.com" <ak@...ux.intel.com>,
        "Wysocki, Rafael J" <rafael.j.wysocki@...el.com>,
        "kirill.shutemov@...ux.intel.com" <kirill.shutemov@...ux.intel.com>,
        "Christopherson,, Sean" <seanjc@...gle.com>,
        "Chatre, Reinette" <reinette.chatre@...el.com>,
        "pbonzini@...hat.com" <pbonzini@...hat.com>,
        "tglx@...utronix.de" <tglx@...utronix.de>,
        "linux-mm@...ck.org" <linux-mm@...ck.org>,
        "Yamahata, Isaku" <isaku.yamahata@...el.com>,
        "peterz@...radead.org" <peterz@...radead.org>,
        "Shahar, Sagi" <sagis@...gle.com>,
        "imammedo@...hat.com" <imammedo@...hat.com>,
        "Gao, Chao" <chao.gao@...el.com>,
        "Brown, Len" <len.brown@...el.com>,
        "sathyanarayanan.kuppuswamy@...ux.intel.com" 
        <sathyanarayanan.kuppuswamy@...ux.intel.com>,
        "Huang, Ying" <ying.huang@...el.com>,
        "Williams, Dan J" <dan.j.williams@...el.com>
Subject: Re: [PATCH v9 07/18] x86/virt/tdx: Do TDX module per-cpu
 initialization

On Mon, 2023-02-13 at 14:43 -0800, Dave Hansen wrote:
> On 2/13/23 13:19, Huang, Kai wrote:
> > > On 2/13/23 03:59, Kai Huang wrote:
> > > > To avoid duplicated code, add a
> > > > helper to call SEAMCALL on all online cpus one by one but with a skip
> > > > function to check whether to skip certain cpus, and use that helper to
> > > > do the per-cpu initialization.
> > > ...
> > > > +/*
> > > > + * Call @func on all online cpus one by one but skip those cpus
> > > > + * when @skip_func is valid and returns true for them.
> > > > + */
> > > > +static int tdx_on_each_cpu_cond(int (*func)(void *), void *func_data,
> > > > +                           bool (*skip_func)(int cpu, void *),
> > > > +                           void *skip_data)
> > > I only see one caller of this.  Where is the duplicated code?
> > The other caller is in patch 15 (x86/virt/tdx: Configure global KeyID on all packages).
> > 
> > I kinda mentioned this in the changelog:
> > 
> >         " Similar to the per-cpu module initialization, a later step to config the key for the global KeyID..."
> > 
> > If we don't have this helper, then we can end up with having below loop in two functions:
> > 
> >         for_each_online(cpu) {
> >                 if (should_skip(cpu))
> >                         continue;
> > 
> >                 // call @func on @cpu.
> >         }
> 
> I don't think saving two lines of actual code is worth the opacity that
> results from this abstraction.

Alright thanks for the suggestion.  I'll remove this tdx_on_each_cpu_cond() and
do directly.

But just checking:

LP.INIT can actually be called in parallel on different cpus (doesn't have to,
of course), so we can actually just use on_each_cpu_cond() for LP.INIT:

	on_each_cpu_cond(should_skip_cpu, smp_func_module_lp_init, NULL, true);

But IIUC Peter doesn't like using IPI and prefers using via work:

https://lore.kernel.org/lkml/Y30dujuXC8wlLwoQ@hirez.programming.kicks-ass.net/

So I used smp_call_on_cpu() here, which only calls @func on one cpu, but not a
cpumask.  For LP.INIT ideally we can have something like:

	schedule_on_cpu(struct cpumask *cpus, work_func_t func);

to call @func on a cpu set, but that doesn't exist now, and I don't think it's
worth to introduce it?

So, should I use on_each_cpu_cond(), or use smp_call_on_cpu() here?

(btw for the TDH.SYS.KEY.CONFIG we must do one by one as it cannot run in
parallel on multi cpus, so I'll use smp_call_on_cpu().)

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ