[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4af292e8-9407-2271-8531-51f8e3c96750@intel.com>
Date: Tue, 14 Feb 2023 14:34:57 +0800
From: Xiaoyao Li <xiaoyao.li@...el.com>
To: Sean Christopherson <seanjc@...gle.com>,
Paolo Bonzini <pbonzini@...hat.com>
Cc: kvm@...r.kernel.org, linux-kernel@...r.kernel.org,
Like Xu <like.xu.linux@...il.com>
Subject: Re: [PATCH v2 01/21] KVM: x86: Rename kvm_init_msr_list() to clarify
it inits multiple lists
On 2/10/2023 8:31 AM, Sean Christopherson wrote:
> Rename kvm_init_msr_list() to kvm_init_msr_lists() to clarify that it
> initializes multiple lists: MSRs to save, emulated MSRs, and feature MSRs.
>
> No functional change intended.
>
> Signed-off-by: Sean Christopherson <seanjc@...gle.com>
Reviewed-by: Xiaoyao Li <xiaoyao.li@...el.com>
> ---
> arch/x86/kvm/x86.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/arch/x86/kvm/x86.c b/arch/x86/kvm/x86.c
> index f706621c35b8..7b91f73a837d 100644
> --- a/arch/x86/kvm/x86.c
> +++ b/arch/x86/kvm/x86.c
> @@ -7071,7 +7071,7 @@ static void kvm_probe_msr_to_save(u32 msr_index)
> msrs_to_save[num_msrs_to_save++] = msr_index;
> }
>
> -static void kvm_init_msr_list(void)
> +static void kvm_init_msr_lists(void)
> {
> unsigned i;
>
> @@ -9450,7 +9450,7 @@ static int __kvm_x86_vendor_init(struct kvm_x86_init_ops *ops)
> kvm_caps.max_guest_tsc_khz = max;
> }
> kvm_caps.default_tsc_scaling_ratio = 1ULL << kvm_caps.tsc_scaling_ratio_frac_bits;
> - kvm_init_msr_list();
> + kvm_init_msr_lists();
> return 0;
>
> out_unwind_ops:
Powered by blists - more mailing lists