lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 20 Feb 2023 12:52:23 +0100
From:   Jiri Slaby <jirislaby@...nel.org>
To:     Mohammad Mahfooz <mohammadmahfoozpersonal@...il.com>,
        linux-kernel@...r.kernel.org
Cc:     Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
        Ilpo Järvinen <ilpo.jarvinen@...ux.intel.com>,
        Johan Hovold <johan@...nel.org>,
        Alexander Vorwerk <alexander.vorwerk@...d.uni-goettingen.de>,
        linux-serial@...r.kernel.org
Subject: Re: [PATCH] serial: jsm: Use min_t instead of min

On 19. 02. 23, 21:53, Mohammad Mahfooz wrote:
> Use min_t instead of min to cut down n further if needed.
> 
> Signed-off-by: Mohammad Mahfooz <mohammadmahfoozpersonal@...il.com>
> ---
>   drivers/tty/serial/jsm/jsm_neo.c | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/tty/serial/jsm/jsm_neo.c b/drivers/tty/serial/jsm/jsm_neo.c
> index 0c78f66276cd..4cce1e423b06 100644
> --- a/drivers/tty/serial/jsm/jsm_neo.c
> +++ b/drivers/tty/serial/jsm/jsm_neo.c
> @@ -350,7 +350,7 @@ static void neo_copy_data_from_uart_to_queue(struct jsm_channel *ch)
>   		 * IBM pSeries platform.
>   		 * 15 bytes max appears to be the magic number.
>   		 */
> -		n = min((u32) n, (u32) 12);
> +		n = min_t(u32, n, 12);

Nah, why is "n" signed in the first place? Could you fix that and all 
all those casts in min()s around instead?

-- 
js
suse labs

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ