[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <Y/YbN9GRdUj7f+oj@kadam>
Date: Wed, 22 Feb 2023 16:40:07 +0300
From: Dan Carpenter <error27@...il.com>
To: Philipp Hortmann <philipp.g.hortmann@...il.com>
Cc: Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
linux-staging@...ts.linux.dev, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 7/7] staging: rtl8192e: Remove entry .nic_type from
struct rtl819x_ops
On Tue, Feb 21, 2023 at 09:53:43PM +0100, Philipp Hortmann wrote:
> Remove unchanged entry .nic_type and replace it with constant NIC_8192E.
> This increases readability of the code.
>
> Signed-off-by: Philipp Hortmann <philipp.g.hortmann@...il.com>
> ---
> drivers/staging/rtl8192e/rtl8192e/rtl_core.c | 1 -
> drivers/staging/rtl8192e/rtl8192e/rtl_core.h | 1 -
> drivers/staging/rtl8192e/rtl8192e/rtl_pci.c | 6 +++---
> 3 files changed, 3 insertions(+), 5 deletions(-)
>
> diff --git a/drivers/staging/rtl8192e/rtl8192e/rtl_core.c b/drivers/staging/rtl8192e/rtl8192e/rtl_core.c
> index 2d2f9d4a0ff5..044cab649ff1 100644
> --- a/drivers/staging/rtl8192e/rtl8192e/rtl_core.c
> +++ b/drivers/staging/rtl8192e/rtl8192e/rtl_core.c
> @@ -26,7 +26,6 @@ int hwwep = 1;
> static char *ifname = "wlan%d";
>
> static const struct rtl819x_ops rtl819xp_ops = {
> - .nic_type = NIC_8192E,
> };
Delete.
>
> static struct pci_device_id rtl8192_pci_id_tbl[] = {
> diff --git a/drivers/staging/rtl8192e/rtl8192e/rtl_core.h b/drivers/staging/rtl8192e/rtl8192e/rtl_core.h
> index fa72f8891409..f75cc96052d9 100644
> --- a/drivers/staging/rtl8192e/rtl8192e/rtl_core.h
> +++ b/drivers/staging/rtl8192e/rtl8192e/rtl_core.h
> @@ -204,7 +204,6 @@ struct rtl8192_tx_ring {
> };
>
> struct rtl819x_ops {
> - enum nic_t nic_type;
> };
Delete this empty struct too.
Otherwise these patches are really nice. Thanks!
regards,
dan carpenter
Powered by blists - more mailing lists