[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20230227183151.27912-1-pmalgujar@marvell.com>
Date: Mon, 27 Feb 2023 10:31:45 -0800
From: Piyush Malgujar <pmalgujar@...vell.com>
To: <linux-mmc@...r.kernel.org>, <linux-kernel@...r.kernel.org>,
<adrian.hunter@...el.com>, <ulf.hansson@...aro.org>,
<robh+dt@...nel.org>, <krzysztof.kozlowski+dt@...aro.org>,
<yamada.masahiro@...ionext.com>, <devicetree@...r.kernel.org>
CC: <jannadurai@...vell.com>, <cchavva@...vell.com>,
Piyush Malgujar <pmalgujar@...vell.com>
Subject: [PATCH v3 0/6] mmc: sdhci-cadence: SD6 controller support
Added changes to support SD6 controller
- Restructure and reformat the code.
- Add SD6 related operations.
- Support added for MMC_SDHCI_IO_ACCESSORS.
- Related changes done in dt bindings.
- Support for debug option.
Changes since V2:
- Added separate patches for renaming of functions and
restructuring, adding new structures to support SD4/SD6 operations.
- Added proper suffixes to properties in dt binding.
- Removed unreachable code.
- Handled sdhci_cdns_uniphier_pltfm_data similar to sdhci_cdns_sd4_of_data
as per the added structured design.
- Used dev_dbg instead of DEBUG_DRV in debug patch.
Changes since V1:
- Added separate patch for reformat/rename changes.
- Enabled MMC_SDHCI_IO_ACCESSORS in config MMC_SDHCI_CADENCE.
- Used proper properties in dt binding.
- Removed patch of config option to change default for sdhci timeout.
- Resolved issues reported by:
Reported-by: kernel test robot <lkp@...el.com>
Reported-by: Dan Carpenter <error27@...il.com>
Dhananjay Kangude (3):
mmc: sdhci-cadence: Rename functions to SD4 specific
mmc: sdhci-cadence: Restructure the code
mmc: sdhci-cadence: SD6 controller support
Jayanthi Annadurai (3):
mmc: sdhci-cadence: enable MMC_SDHCI_IO_ACCESSORS
dt-bindings: mmc: sdhci-cadence: SD6 support
mmc: sdhci-cadence: Add debug option for sdhci-cadence driver
.../devicetree/bindings/mmc/cdns,sdhci.yaml | 24 +-
drivers/mmc/host/Kconfig | 1 +
drivers/mmc/host/sdhci-cadence.c | 1651 ++++++++++++++++-
3 files changed, 1612 insertions(+), 64 deletions(-)
--
2.17.1
Powered by blists - more mailing lists