[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20230309080923.11778-1-ilpo.jarvinen@linux.intel.com>
Date: Thu, 9 Mar 2023 10:09:15 +0200
From: Ilpo Järvinen <ilpo.jarvinen@...ux.intel.com>
To: linux-serial@...r.kernel.org,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Jiri Slaby <jirislaby@...nel.org>
Cc: linux-kernel@...r.kernel.org,
Ilpo Järvinen <ilpo.jarvinen@...ux.intel.com>
Subject: [PATCH 0/8] serial: Core cleanups
Serial core cleanups.
Ilpo Järvinen (8):
serial: Use ARRAY_SIZE() with iso7816 reserved array
serial: Use B0 instead of implicit zero assumption
serial: Remove extern from func prototypes in headers
serial: Move uart_change_speed() earlier
serial: Rename uart_change_speed() to uart_change_line_settings()
serial: Make hw_stopped bool
serial: Rename hw_stopped to old_hw_stopped & improve logic
serial: Remove uart_wait_until_sent() forward declaration
drivers/tty/serial/serial_core.c | 113 +++++++++++++++----------------
include/linux/serial_8250.h | 41 +++++------
include/linux/serial_core.h | 15 ++--
3 files changed, 80 insertions(+), 89 deletions(-)
--
2.30.2
Powered by blists - more mailing lists