[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20230315181902.4177819-13-joel@joelfernandes.org>
Date: Wed, 15 Mar 2023 18:19:00 +0000
From: "Joel Fernandes (Google)" <joel@...lfernandes.org>
To: Zhu Yanjun <zyjzyj2000@...il.com>, Jason Gunthorpe <jgg@...pe.ca>,
Leon Romanovsky <leon@...nel.org>,
Devesh Sharma <devesh.s.sharma@...cle.com>,
Bob Pearson <rpearsonhpe@...il.com>
Cc: "Joel Fernandes (Google)" <joel@...lfernandes.org>,
"Paul E . McKenney" <paulmck@...nel.org>,
Zhu Yanjun <yanjun.zhu@...ux.dev>, linux-rdma@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: [PATCH v2 13/14] RDMA/rxe: Rename kfree_rcu() to kvfree_rcu_mightsleep()
The k[v]free_rcu() macro's single-argument form is deprecated.
Therefore switch to the new k[v]free_rcu_mightsleep() variant. The goal
is to avoid accidental use of the single-argument forms, which can
introduce functionality bugs in atomic contexts and latency bugs in
non-atomic contexts.
There is no functionality change with this patch.
Link: https://lore.kernel.org/rcu/20230201150815.409582-1-urezki@gmail.com
Acked-by: Zhu Yanjun <zyjzyj2000@...il.com>
Reviewed-by: Bob Pearson <rpearsonhpe@...il.com>
Reviewed-by: Paul E. McKenney <paulmck@...nel.org>
Fixes: 72a03627443d ("RDMA/rxe: Remove rxe_alloc()")
Signed-off-by: Joel Fernandes (Google) <joel@...lfernandes.org>
---
drivers/infiniband/sw/rxe/rxe_mr.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/infiniband/sw/rxe/rxe_mr.c b/drivers/infiniband/sw/rxe/rxe_mr.c
index b10aa1580a64..ae3a100e18fb 100644
--- a/drivers/infiniband/sw/rxe/rxe_mr.c
+++ b/drivers/infiniband/sw/rxe/rxe_mr.c
@@ -731,7 +731,7 @@ int rxe_dereg_mr(struct ib_mr *ibmr, struct ib_udata *udata)
return -EINVAL;
rxe_cleanup(mr);
- kfree_rcu(mr);
+ kfree_rcu_mightsleep(mr);
return 0;
}
--
2.40.0.rc1.284.g88254d51c5-goog
Powered by blists - more mailing lists