lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <97aced64-c0ac-6041-41cd-ae3439216089@arm.com>
Date:   Wed, 15 Mar 2023 12:18:31 +0000
From:   Robin Murphy <robin.murphy@....com>
To:     "Kirill A. Shutemov" <kirill.shutemov@...ux.intel.com>,
        Andrew Morton <akpm@...ux-foundation.org>,
        Mel Gorman <mgorman@...e.de>, Vlastimil Babka <vbabka@...e.cz>,
        David Hildenbrand <david@...hat.com>
Cc:     linux-mm@...ck.org, linux-arch@...r.kernel.org,
        linux-kernel@...r.kernel.org,
        Jacob Pan <jacob.jun.pan@...ux.intel.com>,
        Joerg Roedel <joro@...tes.org>
Subject: Re: [PATCH 09/10] iommu: Fix MAX_ORDER usage in
 __iommu_dma_alloc_pages()

On 2023-03-15 11:31, Kirill A. Shutemov wrote:
> MAX_ORDER is not inclusive: the maximum allocation order buddy allocator
> can deliver is MAX_ORDER-1.
> 
> Fix MAX_ORDER usage in __iommu_dma_alloc_pages().

Technically this isn't a major issue - all it means is that if we did 
happen to have a suitable page size which lined up with MAX_ORDER, we'd 
unsuccessfully try the allocation once before falling back to the order 
of the next-smallest page size anyway. Semantically you're correct 
though, and I probably did still misunderstand MAX_ORDER 7 years ago :)

> Also use GENMASK() instead of hard to read "(2U << order) - 1" magic.

ISTR that GENMASK() had a habit of generating pretty terrible code for 
non-constant arguments, but a GCC9 build for arm64 looks fine - in fact 
if anything it seems to be able to optimise out more of the __fls() this 
way and save a couple more instructions, which is nice, so:

Acked-by: Robin Murphy <robin.murphy@....com>

I'm guessing you probably want to take this through the mm tree - that 
should be fine since I don't expect any conflicting changes in the IOMMU 
tree for now (cc'ing Joerg just as a heads-up).

Cheers,
Robin.

> Signed-off-by: Kirill A. Shutemov <kirill.shutemov@...ux.intel.com>
> Cc: Robin Murphy <robin.murphy@....com>
> Cc: Jacob Pan <jacob.jun.pan@...ux.intel.com>
> ---
>   drivers/iommu/dma-iommu.c | 4 ++--
>   1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/iommu/dma-iommu.c b/drivers/iommu/dma-iommu.c
> index 99b2646cb5c7..ac996fd6bd9c 100644
> --- a/drivers/iommu/dma-iommu.c
> +++ b/drivers/iommu/dma-iommu.c
> @@ -736,7 +736,7 @@ static struct page **__iommu_dma_alloc_pages(struct device *dev,
>   	struct page **pages;
>   	unsigned int i = 0, nid = dev_to_node(dev);
>   
> -	order_mask &= (2U << MAX_ORDER) - 1;
> +	order_mask &= GENMASK(MAX_ORDER - 1, 0);
>   	if (!order_mask)
>   		return NULL;
>   
> @@ -756,7 +756,7 @@ static struct page **__iommu_dma_alloc_pages(struct device *dev,
>   		 * than a necessity, hence using __GFP_NORETRY until
>   		 * falling back to minimum-order allocations.
>   		 */
> -		for (order_mask &= (2U << __fls(count)) - 1;
> +		for (order_mask &= GENMASK(__fls(count), 0);
>   		     order_mask; order_mask &= ~order_size) {
>   			unsigned int order = __fls(order_mask);
>   			gfp_t alloc_flags = gfp;

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ