[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20230321154728.3r7ut3rl2pccmo2e@pengutronix.de>
Date: Tue, 21 Mar 2023 16:47:28 +0100
From: Uwe Kleine-König <u.kleine-koenig@...gutronix.de>
To: Menna Mahmoud <eng.mennamahmoud.mm@...il.com>
Cc: gregkh@...uxfoundation.org, outreachy@...ts.linux.dev,
johan@...nel.org, elder@...nel.org, vireshk@...nel.org,
thierry.reding@...il.com, greybus-dev@...ts.linaro.org,
linux-kernel@...r.kernel.org, linux-staging@...ts.linux.dev,
linux-pwm@...r.kernel.org, Julia Lawall <julia.lawall@...ia.fr>
Subject: Re: [PATCH 2/3] staging: greybus: use inline function for macros
Hello,
just some nitpicks:
On Tue, Mar 21, 2023 at 01:04:33AM +0200, Menna Mahmoud wrote:
> Convert `to_gbphy_dev` and `to_gbphy_driver` macros into a
> static inline function.
>
> it is not great to have macro that use `container_of` macro,
s/it/It/; s/macro/macros/; s/use/use the/;
> because from looking at the definition one cannot tell what type
> it applies to.
> [...]
> -#define to_gbphy_dev(d) container_of(d, struct gbphy_device, dev)
> +static inline struct gbphy_device *to_gbphy_dev(const struct device *d)
drivers/staging/greybus/gbphy.c always passes a variable named
"dev" to this macro. So I'd call the parameter "dev", too, instead of
"d". This is also a more typical name for variables of that type.
> +{
> + return container_of(d, struct gbphy_device, dev);
> +}
> [...]
> };
> -#define to_gbphy_driver(d) container_of(d, struct gbphy_driver, driver)
> +static inline struct gbphy_driver *to_gbphy_driver(struct device_driver *d)
> +{
> + return container_of(d, struct gbphy_driver, driver);
> +}
With a similar reasoning (and also to not have "d"s that are either
device or device_driver) I'd recommend "drv" here.
Best regards
Uwe
--
Pengutronix e.K. | Uwe Kleine-König |
Industrial Linux Solutions | https://www.pengutronix.de/ |
Download attachment "signature.asc" of type "application/pgp-signature" (489 bytes)
Powered by blists - more mailing lists