[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <4f1096f0-cb6e-7cd2-5f41-c5e4b53fa407@suse.cz>
Date: Wed, 29 Mar 2023 10:41:52 +0200
From: Vlastimil Babka <vbabka@...e.cz>
To: "chenjun (AM)" <chenjun102@...wei.com>,
Mike Rapoport <rppt@...nel.org>
Cc: "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"linux-mm@...ck.org" <linux-mm@...ck.org>,
"cl@...ux.com" <cl@...ux.com>,
"penberg@...nel.org" <penberg@...nel.org>,
"rientjes@...gle.com" <rientjes@...gle.com>,
"iamjoonsoo.kim@....com" <iamjoonsoo.kim@....com>,
"akpm@...ux-foundation.org" <akpm@...ux-foundation.org>,
Hyeonggon Yoo <42.hyeyoo@...il.com>,
"xuqiang (M)" <xuqiang36@...wei.com>,
"Wangkefeng (OS Kernel Lab)" <wangkefeng.wang@...wei.com>,
Michal Hocko <mhocko@...nel.org>,
Mel Gorman <mgorman@...hsingularity.net>
Subject: Re: [PATCH] mm/slub: Reduce memory consumption in extreme scenarios
On 3/21/23 10:30, chenjun (AM) wrote:
> 在 2023/3/20 17:12, Mike Rapoport 写道:
>>>>
>>>> If we ignore __GFP_ZERO passed by kzalloc, kzalloc will not work.
>>>> Could we just unmask __GFP_RECLAIMABLE | __GFP_RECLAIM?
>>>>
>>>> pc.flags &= ~(__GFP_RECLAIMABLE | __GFP_RECLAIM)
>>>> pc.flags |= __GFP_THISNODE
>>>
>>> __GFP_RECLAIMABLE would be wrong, but also ignored as new_slab() does:
>>> flags & (GFP_RECLAIM_MASK | GFP_CONSTRAINT_MASK)
>>>
>>> which would filter out __GFP_ZERO as well. That's not a problem as kzalloc()
>>> will zero out the individual allocated objects, so it doesn't matter if we
>>> don't zero out the whole slab page.
>>>
>>> But I wonder, if we're not past due time for a helper e.g.
>>> gfp_opportunistic(flags) that would turn any allocation flags to a
>>> GFP_NOWAIT while keeping the rest of relevant flags intact, and thus there
>>> would be one canonical way to do it - I'm sure there's a number of places
>>> with their own variants now?
>>> With such helper we'd just add __GFP_THISNODE to the result here as that's
>>> specific to this particular opportunistic allocation.
>>
>> I like the idea, but maybe gfp_no_reclaim() would be clearer?
>>
>
> #define gfp_no_reclaim(gfpflag) (gfpflag & ~__GFP_DIRECT_RECLAIM)
I hoped for more feedback on the idea, but it's probably best proposed
outside of this slub-specific thread, so we could go for an open-coded
solution in slub for now.
Also just masking out __GFP_DIRECT_RECLAIM wouldn't be sufficient in any
case for the general solution/
> And here,
>
> pc.flags = gfp_no_reclaim(gfpflags) | __GFP_THISNODE.
I'd still suggest as earlier:
pc.flags = GFP_NOWAIT | __GFP_NOWARN |__GFP_THISNODE;
> Do I get it right?
Powered by blists - more mailing lists