[<prev] [next>] [day] [month] [year] [list]
Message-ID: <20230330125402.764676-1-haowenchao2@huawei.com>
Date: Thu, 30 Mar 2023 20:54:02 +0800
From: Wenchao Hao <haowenchao2@...wei.com>
To: Jens Axboe <axboe@...nel.dk>, <linux-block@...r.kernel.org>,
<linux-kernel@...r.kernel.org>
CC: <linfeilong@...wei.com>, <louhongxiang@...wei.com>,
<haowenchao2@...wei.com>
Subject: [PATCH] blk-mq: rename blk_complete_request to blk_end_request
The name blk_complete_request makes people wonder whether it is a variant
of blk_mq_complete_request, but there is actually no relationship between
them. So rename blk_complete_request to blk_end_request to make it more
appropriate.
Signed-off-by: Wenchao Hao <haowenchao2@...wei.com>
---
block/blk-mq.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/block/blk-mq.c b/block/blk-mq.c
index cf1a39adf9a5..0aa9fd9aacb6 100644
--- a/block/blk-mq.c
+++ b/block/blk-mq.c
@@ -824,7 +824,7 @@ static void blk_print_req_error(struct request *req, blk_status_t status)
* Fully end IO on a request. Does not support partial completions, or
* errors.
*/
-static void blk_complete_request(struct request *req)
+static void blk_end_request(struct request *req)
{
const bool is_flush = (req->rq_flags & RQF_FLUSH_SEQ) != 0;
int total_bytes = blk_rq_bytes(req);
@@ -1089,7 +1089,7 @@ void blk_mq_end_request_batch(struct io_comp_batch *iob)
prefetch(rq->bio);
prefetch(rq->rq_next);
- blk_complete_request(rq);
+ blk_end_request(rq);
if (iob->need_ts)
__blk_mq_end_request_acct(rq, now);
--
2.35.3
Powered by blists - more mailing lists