[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <1b2cf3b4-fd11-43db-7f22-76a762ec8aa6@arm.com>
Date: Wed, 5 Apr 2023 09:52:17 +0530
From: Chaitanya S Prakash <chaitanyas.prakash@....com>
To: linux-mm@...ck.org, linux-kernel@...r.kernel.org
Cc: Andrew Morton <akpm@...ux-foundation.org>,
"Aneesh Kumar K . V" <aneesh.kumar@...ux.ibm.com>,
"Kirill A . Shutemov" <kirill.shutemov@...ux.intel.com>,
Shuah Khan <shuah@...nel.org>, linux-kselftest@...r.kernel.org
Subject: Re: [PATCH 0/5] selftests/mm: Implement support for arm64 on va
On 3/23/23 16:22, Chaitanya S Prakash wrote:
> The va_128TBswitch selftest is designed and implemented for PowerPC and
> x86 architectures which support a 128TB switch, up to 256TB of virtual
> address space and hugepage sizes of 16MB and 2MB respectively. Arm64
> platforms on the other hand support a 256Tb switch, up to 4PB of virtual
> address space and a default hugepage size of 512MB when 64k pagesize is
> enabled.
>
> These architectural differences require introducing support for arm64
> platforms, after which a more generic naming convention is suggested.
> The in code comments are amended to provide a more platform independent
> explanation of the working of the code and nr_hugepages are configured
> as required. Finally, the file running the testcase is modified in order
> to prevent skipping of hugetlb testcases of va_high_addr_switch.
>
> This series has been tested on 6.3.0-rc3 kernel, both on arm64 and x86
> platforms.
Gentle ping, any updates?
>
> Cc: Andrew Morton <akpm@...ux-foundation.org>
> Cc: Aneesh Kumar K.V <aneesh.kumar@...ux.ibm.com>
> Cc: Kirill A. Shutemov <kirill.shutemov@...ux.intel.com>
> Cc: Shuah Khan <shuah@...nel.org>
> Cc: linux-mm@...ck.org
> Cc: linux-kselftest@...r.kernel.org
> Cc: linux-kernel@...r.kernel.org
>
> Chaitanya S Prakash (5):
> selftests/mm: Add support for arm64 platform on va switch
> selftests/mm: Rename va_128TBswitch to va_high_addr_switch
> selftests/mm: Add platform independent in code comments
> selftests/mm: Configure nr_hugepages for arm64
> selftests/mm: Run hugetlb testcases of va switch
>
> tools/testing/selftests/mm/Makefile | 4 +-
> tools/testing/selftests/mm/run_vmtests.sh | 12 +++++-
> ...va_128TBswitch.c => va_high_addr_switch.c} | 41 +++++++++++++++----
> ..._128TBswitch.sh => va_high_addr_switch.sh} | 6 ++-
> 4 files changed, 49 insertions(+), 14 deletions(-)
> rename tools/testing/selftests/mm/{va_128TBswitch.c => va_high_addr_switch.c} (86%)
> rename tools/testing/selftests/mm/{va_128TBswitch.sh => va_high_addr_switch.sh} (89%)
>
Powered by blists - more mailing lists