[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAEXTbpfwMBOTSe3Vp8arTGK1hanrS7qZTFeaN+qN148XcZ4-Fg@mail.gmail.com>
Date: Fri, 7 Apr 2023 00:50:16 +0900
From: Pin-yen Lin <treapking@...omium.org>
To: Rob Herring <robh@...nel.org>
Cc: Andrzej Hajda <andrzej.hajda@...el.com>,
Neil Armstrong <neil.armstrong@...aro.org>,
Robert Foss <rfoss@...nel.org>,
Laurent Pinchart <Laurent.pinchart@...asonboard.com>,
Jonas Karlman <jonas@...boo.se>,
Jernej Skrabec <jernej.skrabec@...il.com>,
David Airlie <airlied@...il.com>,
Daniel Vetter <daniel@...ll.ch>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@...aro.org>,
Andy Shevchenko <andriy.shevchenko@...ux.intel.com>,
Daniel Scally <djrscally@...il.com>,
Heikki Krogerus <heikki.krogerus@...ux.intel.com>,
Sakari Ailus <sakari.ailus@...ux.intel.com>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
"Rafael J . Wysocki" <rafael@...nel.org>,
Prashant Malani <pmalani@...omium.org>,
Benson Leung <bleung@...omium.org>,
Guenter Roeck <groeck@...omium.org>,
Xin Ji <xji@...logixsemi.com>, Marek Vasut <marex@...x.de>,
Hsin-Yi Wang <hsinyi@...omium.org>,
Thomas Zimmermann <tzimmermann@...e.de>,
AngeloGioacchino Del Regno
<angelogioacchino.delregno@...labora.com>,
Lyude Paul <lyude@...hat.com>, devicetree@...r.kernel.org,
Stephen Boyd <swboyd@...omium.org>,
dri-devel@...ts.freedesktop.org, linux-acpi@...r.kernel.org,
chrome-platform@...ts.linux.dev,
Nícolas F . R . A . Prado
<nfraprado@...labora.com>,
Javier Martinez Canillas <javierm@...hat.com>,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH v15 08/10] dt-bindings: display: bridge: it6505: Add
mode-switch support
Hi Rob,
Thanks for the review.
On Fri, Apr 7, 2023 at 12:15 AM Rob Herring <robh@...nel.org> wrote:
>
> On Fri, Mar 31, 2023 at 05:11:43PM +0800, Pin-yen Lin wrote:
> > ITE IT6505 can be used in systems to switch the DP traffic between
> > two downstreams, which can be USB Type-C DisplayPort alternate mode
> > lane or regular DisplayPort output ports.
> >
> > Update the binding to accommodate this usage by introducing a
> > data-lanes and a mode-switch property on endpoints.
> >
> > Signed-off-by: Pin-yen Lin <treapking@...omium.org>
> >
> > ---
> >
> > (no changes since v12)
> >
> > Changes in v12:
> > - Fixed the schema of "data-lanes" property for it6505
> > - Reworded the description of the mode-switch property
> >
> > Changes in v11:
> > - Updated the description of the endpoints in the bindings
> > - Referenced video-interfaces.yaml instead for the endpoints binding
> > - Removed duplicated definitions from inherited schema
> >
> > Changes in v9:
> > - Fixed subject prefix again
> > - Changed the naming of the example node for it6505
> >
> > Changes in v8:
> > - Updated bindings for data-lanes property
> > - Fixed subject prefix
> >
> > Changes in v7:
> > - Fixed issues reported by dt_binding_check.
> > - Updated the schema and the example dts for data-lanes.
> > - Changed to generic naming for the example dts node.
> >
> > Changes in v6:
> > - Remove switches node and use endpoints and data-lanes property to
> > describe the connections.
> >
> > .../bindings/display/bridge/ite,it6505.yaml | 101 +++++++++++++++---
> > 1 file changed, 88 insertions(+), 13 deletions(-)
> >
> > diff --git a/Documentation/devicetree/bindings/display/bridge/ite,it6505.yaml b/Documentation/devicetree/bindings/display/bridge/ite,it6505.yaml
> > index c9a882ee6d98..348b02f26041 100644
> > --- a/Documentation/devicetree/bindings/display/bridge/ite,it6505.yaml
> > +++ b/Documentation/devicetree/bindings/display/bridge/ite,it6505.yaml
> > @@ -75,22 +75,49 @@ properties:
> > port@1:
> > $ref: /schemas/graph.yaml#/$defs/port-base
> > unevaluatedProperties: false
> > - description: Video port for DP output
> > + description:
> > + Video port for DP output. Each endpoint connects to a video output
> > + downstream, and the "data-lanes" property is used to describe the pin
> > + connections. 0, 1, 2, 3 in "data-lanes" maps to TX0, TX1, TX2, TX3,
> > + respectively.
> >
> > - properties:
> > - endpoint:
> > - $ref: /schemas/graph.yaml#/$defs/endpoint-base
> > +
> > + patternProperties:
> > + "^endpoint@[01]$":
> > + $ref: /schemas/media/video-interfaces.yaml#
> > unevaluatedProperties: false
> >
> > properties:
> > + reg: true
> > +
> > + remote-endpoint: true
>
> You don't need to list these 2.
>
> > +
> > data-lanes:
> > - minItems: 1
> > - uniqueItems: true
> > - items:
> > - - enum: [ 0, 1 ]
> > - - const: 1
> > - - const: 2
> > - - const: 3
> > + oneOf:
> > + - items:
> > + - enum: [0, 3]
>
> Only lane 1 wasn't valid? If so, mention that in the commit message.
Tha IT6505 bridge only supports "lane swapping" that reverses the
output pins, so only lane 1 or lane 2 is not valid. I'll update this
in the commit message as well.
>
> > +
> > + - items:
> > + - const: 0
> > + - const: 1
> > +
> > + - items:
> > + - const: 3
> > + - const: 2
> > +
> > + - items:
> > + - const: 0
> > + - const: 1
> > + - const: 2
> > + - const: 3
>
> Isn't this the default if 'data-lanes' is omitted.
I don't think we have a "default" in the IT6505 driver because it
currently doesn't have any use case that has all 4 pins described in
an output node. The old use case uses an extcon node to describe the
output, and a 4-pin connection makes no sense for mode switches.
However, we can drop this binding and make it the default when
'data-lanes' is omitted. This will be useful when we migrate the
extcon description to the an output port node.
>
> > +
> > + mode-switch:
> > + type: boolean
> > + description: Serves as Type-C mode switch if present.
> > +
> > + required:
> > + - reg
> > + - remote-endpoint
>
> required can be dropped.
>
> >
> > required:
> > - port@0
> > @@ -102,7 +129,6 @@ required:
> > - pwr18-supply
> > - interrupts
> > - reset-gpios
> > - - extcon
> > - ports
> >
> > additionalProperties: false
> > @@ -139,8 +165,11 @@ examples:
> > };
> >
> > port@1 {
> > + #address-cells = <1>;
> > + #size-cells = <0>;
> > reg = <1>;
> > - it6505_out: endpoint {
> > + it6505_out: endpoint@0 {
> > + reg = <0>;
> > remote-endpoint = <&dp_in>;
> > data-lanes = <0 1>;
> > };
> > @@ -148,3 +177,49 @@ examples:
> > };
> > };
> > };
> > + - |
> > + #include <dt-bindings/interrupt-controller/irq.h>
> > +
> > + i2c {
>
> Why do we need a whole new example? Just extend the existing example
> with new properties/nodes.
I added a new example because I don't think extcon and mode switches
can co-exist. Should I merge the examples to one anyway?
>
> Rob
I'll address other comments in the next version.
Best regards,
Pin-yen
Powered by blists - more mailing lists