[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <c24a071e-b191-4626-8edc-1658a01d80ef@roeck-us.net>
Date: Mon, 10 Apr 2023 09:53:08 -0700
From: Guenter Roeck <linux@...ck-us.net>
To: Aleksa Savic <savicaleksa83@...il.com>
Cc: linux-hwmon@...r.kernel.org, Jack Doan <me@...kdoan.com>,
Jean Delvare <jdelvare@...e.com>,
Leonard Anderweit <leonard.anderweit@...il.com>,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH] hwmon: (aquacomputer_d5next) Fix alignment of function
call params
On Sun, Apr 09, 2023 at 08:35:49PM +0200, Aleksa Savic wrote:
> checkpatch warns that alignment of parameters of function call around
> line 869 is off. Indent them properly.
>
> Fixes: 6f5cdf9b9a86 ("hwmon: (aquacomputer_d5next) Add fan PWM control for Aquaero")
> Signed-off-by: Aleksa Savic <savicaleksa83@...il.com>
> ---
> drivers/hwmon/aquacomputer_d5next.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/hwmon/aquacomputer_d5next.c b/drivers/hwmon/aquacomputer_d5next.c
> index 3bd35d833e69..7db7769fe044 100644
> --- a/drivers/hwmon/aquacomputer_d5next.c
> +++ b/drivers/hwmon/aquacomputer_d5next.c
> @@ -867,8 +867,8 @@ static int aqc_read(struct device *dev, enum hwmon_sensor_types type, u32 attr,
> switch (priv->kind) {
> case aquaero:
> ret = aqc_get_ctrl_val(priv,
> - AQUAERO_CTRL_PRESET_START + channel * AQUAERO_CTRL_PRESET_SIZE,
> - val, AQC_BE16);
> + AQUAERO_CTRL_PRESET_START +
> + channel * AQUAERO_CTRL_PRESET_SIZE, val, AQC_BE16);
I am not sure I understand how this would improve readability.
It seems to accomplish the opposite. Sure, I know, checkpatch --strict
complains, but that is still better than unreadable code just to make
checkpatch happy.
Guenter
Powered by blists - more mailing lists