lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1e3e917a-17ff-2a06-e127-e0d43b731301@starfivetech.com>
Date:   Wed, 12 Apr 2023 14:42:40 +0800
From:   Changhuang Liang <changhuang.liang@...rfivetech.com>
To:     Conor Dooley <conor@...nel.org>
CC:     Rob Herring <robh+dt@...nel.org>,
        Krzysztof Kozlowski <krzysztof.kozlowski+dt@...aro.org>,
        Emil Renner Berthing <kernel@...il.dk>,
        Paul Walmsley <paul.walmsley@...ive.com>,
        Palmer Dabbelt <palmer@...belt.com>,
        Albert Ou <aou@...s.berkeley.edu>,
        Walker Chen <walker.chen@...rfivetech.com>,
        <devicetree@...r.kernel.org>, <linux-kernel@...r.kernel.org>,
        <linux-riscv@...ts.infradead.org>
Subject: Re: [PATCH v1 4/7] soc: starfive: Add pmu type operation



On 2023/4/12 4:52, Conor Dooley wrote:
> Hey Changhuang Liang,
> 
> On Mon, Apr 10, 2023 at 11:47:40PM -0700, Changhuang Liang wrote:
>> Add pmu type, make a distinction between different PMU.
> 
> Please write more detailed commit messages, thanks.
> 

OK, will write more detail for it.

>>
>> Signed-off-by: Changhuang Liang <changhuang.liang@...rfivetech.com>
>> ---
>>  drivers/soc/starfive/jh71xx_pmu.c | 55 ++++++++++++++++++++++---------
>>  1 file changed, 39 insertions(+), 16 deletions(-)
>>
>> diff --git a/drivers/soc/starfive/jh71xx_pmu.c b/drivers/soc/starfive/jh71xx_pmu.c
>> index 306218c83691..98f6849d61de 100644
>> --- a/drivers/soc/starfive/jh71xx_pmu.c
>> +++ b/drivers/soc/starfive/jh71xx_pmu.c
>> @@ -45,6 +45,12 @@
>>   */
>>  #define JH71XX_PMU_TIMEOUT_US		100
>>  
>> +/* pmu type */
> 
> Delete this comment, it's obvious.
> 

OK, will delete this line.

>> +enum pmu_type {
>> +	JH71XX_PMU_GENERAL,
> 
> I'm really not sold on GENERAL as a name.
> Why not name these after the compatibles?
>

OK, will change to "JH71XX_PMU".
 
>> +	JH71XX_PMU_DPHY,
>> +};
>> +
>>  struct jh71xx_domain_info {
>>  	const char * const name;
>>  	unsigned int flags;
>> @@ -54,6 +60,7 @@ struct jh71xx_domain_info {
>>  struct jh71xx_pmu_match_data {
>>  	const struct jh71xx_domain_info *domain_info;
>>  	int num_domains;
>> +	u8 pmu_type;
> 
> This is an enum, not a u8?
> 

OK, will fix it.

> Thanks,
> Conor.
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ