[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <3249ca98-6293-a83d-d49b-d1d52827a062@loongson.cn>
Date: Thu, 13 Apr 2023 09:58:53 +0800
From: Tiezhu Yang <yangtiezhu@...ngson.cn>
To: Xi Ruoyao <xry111@...111.site>,
Huacai Chen <chenhuacai@...nel.org>,
WANG Xuerui <kernel@...0n.name>
Cc: loongarch@...ts.linux.dev, linux-kernel@...r.kernel.org,
loongson-kernel@...ts.loongnix.cn
Subject: Re: [PATCH v1 3/4] LoongArch: Use larch_insn_gen_break() for kprobes
On 04/12/2023 07:08 PM, Xi Ruoyao wrote:
> On Wed, 2023-04-12 at 18:05 +0800, Tiezhu Yang wrote:
>> -static inline bool insns_not_supported(union loongarch_instruction insn)
>> +static inline bool insns_not_supported(u32 code)
>> {
>> + union loongarch_instruction insn;
>> +
>> + insn.word = code;
>> +
>
> I remember Xuerui disliked this change. Maybe we can add
> __attribute__ (__transparent_union__) [1] for union
> loongarch_instruction instead?
>
> [1]: https://gcc.gnu.org/onlinedocs/gcc/Common-Type-Attributes.html#index-transparent_005funion-type-attribute
>
OK, let me pass union parameter, then define a local variable
to do type conversion for callers, the changes are small and
then the code may be more readable, thank you.
Thanks,
Tiezhu
Powered by blists - more mailing lists