[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20230414110821.21548-1-p.raghav@samsung.com>
Date: Fri, 14 Apr 2023 13:08:17 +0200
From: Pankaj Raghav <p.raghav@...sung.com>
To: brauner@...nel.org, willy@...radead.org, viro@...iv.linux.org.uk,
akpm@...ux-foundation.org
Cc: linux-fsdevel@...r.kernel.org, linux-kernel@...r.kernel.org,
mcgrof@...nel.org, gost.dev@...sung.com, hare@...e.de,
Pankaj Raghav <p.raghav@...sung.com>
Subject: [RFC 0/4] convert create_page_buffers to create_folio_buffers
One of the first kernel panic we hit when we try to increase the
block size > 4k is inside create_page_buffers()[1]. Even though buffer.c
function do not support large folios (folios > PAGE_SIZE) at the moment,
these changes are required when we want to remove that constraint.
Willy had already mentioned that he wanted to convert create_page_buffers to
create_folio_buffers but didn't get to it yet, so I decided to take a
shot.
No functional changes introduced.
OI:
- I don't like the fact that I had to introduce
folio_create_empty_buffers() as create_empty_buffers() is used in
many parts of the kernel. Should I do a big bang change as a part of
this series where we convert create_empty_buffers to take a folio and
change the callers to pass a folio instead of a page?
- I split the series into 4 commits for clarity. I could squash them
into one patch if needed.
[1] https://lore.kernel.org/all/ZBnGc4WbBOlnRUgd@casper.infradead.org/
Pankaj Raghav (4):
fs/buffer: add set_bh_folio helper
buffer: add alloc_folio_buffers() helper
fs/buffer: add folio_create_empty_buffers helper
fs/buffer: convert create_page_buffers to create_folio_buffers
fs/buffer.c | 131 +++++++++++++++++++++++++++++++++---
include/linux/buffer_head.h | 4 ++
2 files changed, 125 insertions(+), 10 deletions(-)
--
2.34.1
Powered by blists - more mailing lists