[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAOssrKfCiByavRNekRUOCv==AEvWAO6B6=tAASyYdvWj9XRhBw@mail.gmail.com>
Date: Wed, 19 Apr 2023 10:05:23 +0200
From: Miklos Szeredi <mszeredi@...hat.com>
To: Haifeng Xu <haifeng.xu@...pee.com>
Cc: viro@...iv.linux.org.uk, bigeasy@...utronix.de, mcgrof@...nel.org,
xiubli@...hat.com, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 2/2] vfs: clean up d_backing_inode() function
If we are touching that function, I'd just get rid of it completely
(s/d_backing_inode/d_inode/).
Thanks,
Miklos
On Wed, Apr 19, 2023 at 9:27 AM Haifeng Xu <haifeng.xu@...pee.com> wrote:
>
> Using an extra variable to record the inode is unnecessary, return it
> directly.
>
> Signed-off-by: Haifeng Xu <haifeng.xu@...pee.com>
> ---
> include/linux/dcache.h | 4 +---
> 1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/include/linux/dcache.h b/include/linux/dcache.h
> index 13023c7211d6..97324b6434e5 100644
> --- a/include/linux/dcache.h
> +++ b/include/linux/dcache.h
> @@ -540,9 +540,7 @@ static inline struct inode *d_inode_rcu(const struct dentry *dentry)
> */
> static inline struct inode *d_backing_inode(const struct dentry *upper)
> {
> - struct inode *inode = upper->d_inode;
> -
> - return inode;
> + return upper->d_inode;
> }
>
> /**
> --
> 2.25.1
>
Powered by blists - more mailing lists