lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <59cfa762-24c8-5b53-feca-517250192d65@intel.com>
Date:   Fri, 21 Apr 2023 17:14:13 -0700
From:   Reinette Chatre <reinette.chatre@...el.com>
To:     Ilpo Järvinen <ilpo.jarvinen@...ux.intel.com>,
        <linux-kselftest@...r.kernel.org>,
        Fenghua Yu <fenghua.yu@...el.com>,
        "Shuah Khan" <shuah@...nel.org>, <linux-kernel@...r.kernel.org>
CC:     Shaopeng Tan <tan.shaopeng@...fujitsu.com>
Subject: Re: [PATCH v2 07/24] selftests/resctrl: Remove duplicated preparation
 for span arg

Hi Ilpo,

On 4/18/2023 4:44 AM, Ilpo Järvinen wrote:
> When no benchmark_cmd is given, benchmark_cmd[1] is set to span in
> main(). There's no need to do it again in run_mba_test().
> 
> Remove the duplicated preparation for span argument into
> benchmark_cmd[1] from run_mba_test(). It enables also removing has_ben
> argument from run_mba_test() as unnecessary.

I find the last sentence a bit hard to read. How about
"After this, the has_ben argument to run_mba_test() can be removed.".

> 
> Co-developed-by: Fenghua Yu <fenghua.yu@...el.com>
> Signed-off-by: Fenghua Yu <fenghua.yu@...el.com>
> Signed-off-by: Ilpo Järvinen <ilpo.jarvinen@...ux.intel.com>
> ---
>  tools/testing/selftests/resctrl/resctrl_tests.c | 8 +++-----
>  1 file changed, 3 insertions(+), 5 deletions(-)
> 
> diff --git a/tools/testing/selftests/resctrl/resctrl_tests.c b/tools/testing/selftests/resctrl/resctrl_tests.c
> index f1ed2c89f228..3c8ec68eb507 100644
> --- a/tools/testing/selftests/resctrl/resctrl_tests.c
> +++ b/tools/testing/selftests/resctrl/resctrl_tests.c
> @@ -99,8 +99,8 @@ static void run_mbm_test(bool has_ben, char **benchmark_cmd, unsigned long span,
>  	umount_resctrlfs();
>  }
>  
> -static void run_mba_test(bool has_ben, char **benchmark_cmd, unsigned long span,
> -			 int cpu_no, char *bw_report)
> +static void run_mba_test(char **benchmark_cmd, unsigned long span, int cpu_no,
> +			 char *bw_report)
>  {
>  	int res;
>  
> @@ -117,8 +117,6 @@ static void run_mba_test(bool has_ben, char **benchmark_cmd, unsigned long span,
>  		goto umount;
>  	}
>  
> -	if (!has_ben)
> -		sprintf(benchmark_cmd[1], "%lu", span);

Can "span" also be removed?

>  	res = mba_schemata_change(cpu_no, bw_report, benchmark_cmd);
>  	ksft_test_result(!res, "MBA: schemata change\n");
>  
> @@ -297,7 +295,7 @@ int main(int argc, char **argv)
>  		run_mbm_test(has_ben, benchmark_cmd, span, cpu_no, bw_report);
>  
>  	if (mba_test)
> -		run_mba_test(has_ben, benchmark_cmd, span, cpu_no, bw_report);
> +		run_mba_test(benchmark_cmd, span, cpu_no, bw_report);
>  
>  	if (cmt_test)
>  		run_cmt_test(has_ben, benchmark_cmd, cpu_no);


Reinette

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ