lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Wed, 26 Apr 2023 16:15:46 +0800
From:   Gao Xiang <hsiangkao@...ux.alibaba.com>
To:     Yue Hu <zbestahu@...il.com>, xiang@...nel.org, chao@...nel.org,
        linux-erofs@...ts.ozlabs.org
Cc:     jefflexu@...ux.alibaba.com, huyue2@...lpad.com,
        linux-kernel@...r.kernel.org, zhangwen@...lpad.com
Subject: Re: [PATCH] erofs: fold in z_erofs_decompress()



On 2023/4/26 15:59, Yue Hu wrote:
> From: Yue Hu <huyue2@...lpad.com>
> 
> No need this helper since it's just a simple wrapper for decompress
> method and only one caller.  So, let's fold in directly instead.
> 
> Signed-off-by: Yue Hu <huyue2@...lpad.com>
> ---
>   fs/erofs/compress.h     | 3 +--
>   fs/erofs/decompressor.c | 8 +-------
>   fs/erofs/zdata.c        | 4 +++-
>   3 files changed, 5 insertions(+), 10 deletions(-)
> 
> diff --git a/fs/erofs/compress.h b/fs/erofs/compress.h
> index 26fa170090b8..9e423316f5a1 100644
> --- a/fs/erofs/compress.h
> +++ b/fs/erofs/compress.h
> @@ -89,8 +89,7 @@ static inline bool erofs_page_is_managed(const struct erofs_sb_info *sbi,
>   
>   int z_erofs_fixup_insize(struct z_erofs_decompress_req *rq, const char *padbuf,
>   			 unsigned int padbufsize);
> -int z_erofs_decompress(struct z_erofs_decompress_req *rq,
> -		       struct page **pagepool);
> +extern const struct z_erofs_decompressor decompressors[];
>   
>   /* prototypes for specific algorithms */
>   int z_erofs_lzma_decompress(struct z_erofs_decompress_req *rq,
> diff --git a/fs/erofs/decompressor.c b/fs/erofs/decompressor.c
> index 7021e2cf6146..5ed82b72a5a5 100644
> --- a/fs/erofs/decompressor.c
> +++ b/fs/erofs/decompressor.c
> @@ -363,7 +363,7 @@ static int z_erofs_transform_plain(struct z_erofs_decompress_req *rq,
>   	return 0;
>   }
>   
> -static struct z_erofs_decompressor decompressors[] = {
> +const struct z_erofs_decompressor decompressors[] = {

Please help rename it as erofs_decompressors.

>   	[Z_EROFS_COMPRESSION_SHIFTED] = {
>   		.decompress = z_erofs_transform_plain,
>   		.name = "shifted"
> @@ -383,9 +383,3 @@ static struct z_erofs_decompressor decompressors[] = {
>   	},
>   #endif
>   };
> -
> -int z_erofs_decompress(struct z_erofs_decompress_req *rq,
> -		       struct page **pagepool)
> -{
> -	return decompressors[rq->alg].decompress(rq, pagepool);
> -}
> diff --git a/fs/erofs/zdata.c b/fs/erofs/zdata.c
> index a90d37c7bdd7..f5c8ab176b23 100644
> --- a/fs/erofs/zdata.c
> +++ b/fs/erofs/zdata.c
> @@ -1290,6 +1290,8 @@ static int z_erofs_decompress_pcluster(struct z_erofs_decompress_backend *be,
>   	struct erofs_sb_info *const sbi = EROFS_SB(be->sb);
>   	struct z_erofs_pcluster *pcl = be->pcl;
>   	unsigned int pclusterpages = z_erofs_pclusterpages(pcl);
> +	struct z_erofs_decompressor decompressor =
> +				decompressors[pcl->algorithmformat];

Do you really need copy the struct item?
	struct z_erofs_decompressor *dec =
			erofs_decompressors[pcl->algorithmformat];

Otherwise it looks good to me.

Thanks,
Gao Xiang

>   	unsigned int i, inputsize;
>   	int err2;
>   	struct page *page;
> @@ -1333,7 +1335,7 @@ static int z_erofs_decompress_pcluster(struct z_erofs_decompress_backend *be,
>   	else
>   		inputsize = pclusterpages * PAGE_SIZE;
>   
> -	err = z_erofs_decompress(&(struct z_erofs_decompress_req) {
> +	err = decompressor.decompress(&(struct z_erofs_decompress_req) {
>   					.sb = be->sb,
>   					.in = be->compressed_pages,
>   					.out = be->decompressed_pages,

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ