[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20230501043007.GB19673@lst.de>
Date: Mon, 1 May 2023 06:30:07 +0200
From: Christoph Hellwig <hch@....de>
To: Breno Leitao <leitao@...ian.org>
Cc: io-uring@...r.kernel.org, linux-nvme@...ts.infradead.org,
asml.silence@...il.com, axboe@...nel.dk, ming.lei@...hat.com,
leit@...com, linux-kernel@...r.kernel.org,
linux-block@...r.kernel.org, sagi@...mberg.me, joshi.k@...sung.com,
hch@....de, kbusch@...nel.org
Subject: Re: [PATCH v3 2/4] io_uring: Pass whole sqe to commands
> static int ublk_ch_uring_cmd(struct io_uring_cmd *cmd, unsigned int issue_flags)
> {
> - struct ublksrv_io_cmd *ub_cmd = (struct ublksrv_io_cmd *)cmd->cmd;
> + struct ublksrv_io_cmd *ub_cmd = (struct ublksrv_io_cmd *)cmd->sqe->cmd;
This still adds all the crazy casting!!
As I already explained two times, last time including actual working
code, please add a helper that takes a io_uring_cmd * argument, and
returns cmd->sqe->cmd with a void * type. With that all the casting
can be removed.
Powered by blists - more mailing lists