lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 1 May 2023 12:37:57 +0800
From:   Lai Jiangshan <jiangshanlai@...il.com>
To:     Randy Dunlap <rdunlap@...radead.org>
Cc:     linux-kernel@...r.kernel.org, Tejun Heo <tj@...nel.org>
Subject: Re: [RFC PATCH] workqueue: fix cast warnings on i386

On Sat, Apr 29, 2023 at 12:45 PM Randy Dunlap <rdunlap@...radead.org> wrote:
>
> Add casts to avoid int-to-pointer-cast warings on i386 or UML for i386:
>
> ../kernel/workqueue.c: In function ‘get_work_pwq’:
> ../kernel/workqueue.c:713:24: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
>   713 |                 return (void *)(data & WORK_STRUCT_WQ_DATA_MASK);
>       |                        ^
> ../kernel/workqueue.c: In function ‘get_work_pool’:
> ../kernel/workqueue.c:741:25: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
>   741 |                 return ((struct pool_workqueue *)
>       |                         ^
> ../kernel/workqueue.c: In function ‘get_work_pool_id’:
> ../kernel/workqueue.c:763:25: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
>   763 |                 return ((struct pool_workqueue *)
>       |                         ^
>

Hello, Randy

Both the type of the "data" and WORK_STRUCT_WQ_DATA_MASK are
"unsigned long", so I don't think "(data & WORK_STRUCT_WQ_DATA_MASK)"
needs to be converted to "unsigned long".

        WORK_STRUCT_FLAG_MASK   = (1UL << WORK_STRUCT_FLAG_BITS) - 1,
        WORK_STRUCT_WQ_DATA_MASK = ~WORK_STRUCT_FLAG_MASK,

This simple fix might hide the real problem.

Thanks
Lai.

> Fixes: e120153ddf86 ("workqueue: fix how cpu number is stored in work->data")
> Fixes: 112202d9098a ("workqueue: rename cpu_workqueue to pool_workqueue")
> Signed-off-by: Randy Dunlap <rdunlap@...radead.org>
> Cc: Tejun Heo <tj@...nel.org>
> Cc: Lai Jiangshan <jiangshanlai@...il.com>
> ---
>  kernel/workqueue.c |    6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff -- a/kernel/workqueue.c b/kernel/workqueue.c
> --- a/kernel/workqueue.c
> +++ b/kernel/workqueue.c
> @@ -710,7 +710,7 @@ static struct pool_workqueue *get_work_p
>         unsigned long data = atomic_long_read(&work->data);
>
>         if (data & WORK_STRUCT_PWQ)
> -               return (void *)(data & WORK_STRUCT_WQ_DATA_MASK);
> +               return (void *)(unsigned long)(data & WORK_STRUCT_WQ_DATA_MASK);
>         else
>                 return NULL;
>  }
> @@ -739,7 +739,7 @@ static struct worker_pool *get_work_pool
>
>         if (data & WORK_STRUCT_PWQ)
>                 return ((struct pool_workqueue *)
> -                       (data & WORK_STRUCT_WQ_DATA_MASK))->pool;
> +                       (unsigned long)(data & WORK_STRUCT_WQ_DATA_MASK))->pool;
>
>         pool_id = data >> WORK_OFFQ_POOL_SHIFT;
>         if (pool_id == WORK_OFFQ_POOL_NONE)
> @@ -761,7 +761,7 @@ static int get_work_pool_id(struct work_
>
>         if (data & WORK_STRUCT_PWQ)
>                 return ((struct pool_workqueue *)
> -                       (data & WORK_STRUCT_WQ_DATA_MASK))->pool->id;
> +                       (unsigned long)(data & WORK_STRUCT_WQ_DATA_MASK))->pool->id;
>
>         return data >> WORK_OFFQ_POOL_SHIFT;
>  }

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ