[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <8c28baa8-0945-fd77-3d1d-92c99c7bbbd1@efficios.com>
Date: Thu, 4 May 2023 10:54:09 -0400
From: Mathieu Desnoyers <mathieu.desnoyers@...icios.com>
To: "Huang, Ying" <ying.huang@...el.com>
Cc: Andrew Morton <akpm@...ux-foundation.org>,
linux-kernel@...r.kernel.org,
Peter Zijlstra <peterz@...radead.org>,
Linus Torvalds <torvalds@...ux-foundation.org>
Subject: Re: [RFC PATCH 4/4] llist.h: Fix parentheses around macro pointer
parameter use
On 2023-05-04 01:54, Huang, Ying wrote:
> Hi, Mathieu,
>
> Mathieu Desnoyers <mathieu.desnoyers@...icios.com> writes:
>
>> Add missing parentheses around use of macro argument "pos" in those
>> patterns to ensure operator precedence behaves as expected:
>>
>> - typeof(*pos)
>> - pos->member
>>
>> The typeof(*pos) lack of parentheses around "pos" is not an issue per se
>> in the specific macros modified here because "pos" is used as an lvalue,
>> which should prevent use of any operator causing issue. Still add the
>> extra parentheses for consistency.
>
> I don't think it's necessary to add parentheses here. As you said,
> "pos" is used as an lvalue.
I agree that it's not strictly necessary to add the parentheses around
"pos" in typeof(*pos) when pos is also used as an lvalue within a macro,
but if we look at what happened in list.h, we can see why having a consistent
pattern is good to eliminate issues as the code evolves.
When code from list_for_each_entry_continue was lifted into
list_prepare_entry(), we had a situation where "pos" was initially used
as an lvalue in the original macro, but not in list_prepare_entry(), for
which the parentheses were relevant.
This example is from the pre-git era, in tglx's history tree:
commit a3500b9e955d47891e57587c30006de83a3591f5
Author: Linus Torvalds <torvalds@...e.osdl.org>
Date: Wed Feb 11 21:00:34 2004 -0800
Fix "bus_for_each_dev()" and "bus_for_each_drv()", which did not
correctly handle the "restart from this device/driver" case, and
caused oopses with ieee1394.
This just uses "list_for_each_entry_continue()" instead.
Add helper macro to make usage of "list_for_each_entry_continue()"
a bit more readable.
[...]
+/**
+ * list_prepare_entry - prepare a pos entry for use as a start point in
+ * list_for_each_entry_continue
+ * @pos: the type * to use as a start point
+ * @head: the head of the list
+ * @member: the name of the list_struct within the struct.
+ */
+#define list_prepare_entry(pos, head, member) \
+ ((pos) ? : list_entry(head, typeof(*pos), member))
So even though the fact that "pos" is used as an lvalue specifically in
llist_for_each_entry_safe() makes it so that the parentheses are not
strictly required around "pos" in typeof(*pos), I argue that we should
still add those for consistency.
>
>> Remove useless parentheses around use of macro parameter (node) in the
>> following pattern:
>>
>> llist_entry((node), typeof(*pos), member)
>>
>> Because comma is the lowest priority operator already, so the extra pair
>> of parentheses is redundant.
>
> This change looks good for me.
Thanks,
Mathieu
>
> Best Regards,
> Huang, Ying
>
>> Signed-off-by: Mathieu Desnoyers <mathieu.desnoyers@...icios.com>
>> Cc: Andrew Morton <akpm@...ux-foundation.org>
>> Cc: Huang Ying <ying.huang@...el.com>
>> Cc: Peter Zijlstra <peterz@...radead.org>
>> ---
>> include/linux/llist.h | 4 ++--
>> 1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/include/linux/llist.h b/include/linux/llist.h
>> index 85bda2d02d65..45d358c15d0d 100644
>> --- a/include/linux/llist.h
>> +++ b/include/linux/llist.h
>> @@ -173,9 +173,9 @@ static inline void init_llist_head(struct llist_head *list)
>> * reverse the order by yourself before traversing.
>> */
>> #define llist_for_each_entry_safe(pos, n, node, member) \
>> - for (pos = llist_entry((node), typeof(*pos), member); \
>> + for (pos = llist_entry(node, typeof(*(pos)), member); \
>> member_address_is_nonnull(pos, member) && \
>> - (n = llist_entry(pos->member.next, typeof(*n), member), true); \
>> + (n = llist_entry((pos)->member.next, typeof(*(n)), member), true); \
>> pos = n)
>>
>> /**
--
Mathieu Desnoyers
EfficiOS Inc.
https://www.efficios.com
Powered by blists - more mailing lists