lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20230506174651.5c5740d9@jic23-huawei>
Date:   Sat, 6 May 2023 17:46:51 +0100
From:   Jonathan Cameron <jic23@...nel.org>
To:     Mehdi Djait <mehdi.djait.k@...il.com>
Cc:     mazziesaccount@...il.com, krzysztof.kozlowski+dt@...aro.org,
        andriy.shevchenko@...ux.intel.com, robh+dt@...nel.org,
        lars@...afoo.de, linux-iio@...r.kernel.org,
        linux-kernel@...r.kernel.org, devicetree@...r.kernel.org
Subject: Re: [PATCH v3 7/7] iio: accel: Add support for Kionix/ROHM
 KX132-1211 accelerometer

On Fri, 5 May 2023 20:11:33 +0200
Mehdi Djait <mehdi.djait.k@...il.com> wrote:

> Hello Jonathan,
> 
> On Mon, May 01, 2023 at 03:56:45PM +0100, Jonathan Cameron wrote:
> > On Tue, 25 Apr 2023 00:22:27 +0200
> > Mehdi Djait <mehdi.djait.k@...il.com> wrote:
> >   
> > > Kionix KX132-1211 is a tri-axis 16-bit accelerometer that can support
> > > ranges from ±2G to ±16G, digital output through I²C/SPI.
> > > Add support for basic accelerometer features such as reading acceleration
> > > via IIO using raw reads, triggered buffer (data-ready), or the WMI IRQ.
> > > 
> > > Datasheet: https://kionixfs.azureedge.net/en/document/KX132-1211-Technical-Reference-Manual-Rev-5.0.pdf
> > > Signed-off-by: Mehdi Djait <mehdi.djait.k@...il.com>  
> > 
> > Two tiny things inline.  
> >   
> > > +static int kx132_get_fifo_bytes(struct kx022a_data *data)
> > > +{
> > > +	struct device *dev = regmap_get_device(data->regmap);
> > > +	__le16 buf_status;
> > > +	int ret, fifo_bytes;
> > > +
> > > +	ret = regmap_bulk_read(data->regmap, data->chip_info->buf_status1,
> > > +			       &buf_status, sizeof(buf_status));
> > > +	if (ret) {
> > > +		dev_err(dev, "Error reading buffer status\n");
> > > +		return ret;
> > > +	}
> > > +
> > > +	fifo_bytes = le16_to_cpu(buf_status);
> > > +	fifo_bytes &= data->chip_info->buf_smp_lvl_mask;  
> > 
> > Slight preference for FIELD_GET() as it saves me checking the mask includes
> > lowest bits.  
> 
> This will mean I have the remove the chip_info member buf_smp_lvl_mask
> and use KX132_MASK_BUF_SMP_LVL directly because otherwise the
> __builtin_constant_p function will cause an error when building. 
> Check: https://elixir.bootlin.com/linux/latest/source/include/linux/bitfield.h#L65
> 
> I can change it to FIELD_GET() if you want to.

Good point.  You could use le16_get_bits() though which I'm fairly sure will take
a variable just fine.

> 
> > 
> >   
> > > +
> > > +	return fifo_bytes;
> > > +}
> > > +
> > >  static int __kx022a_fifo_flush(struct iio_dev *idev, unsigned int samples,
> > >  			       bool irq)
> > >  {
> > > @@ -1036,6 +1157,32 @@ const struct kx022a_chip_info kx022a_chip_info = {
> > >  };
> > >  EXPORT_SYMBOL_NS_GPL(kx022a_chip_info, IIO_KX022A);
> > >  
> > > +const struct kx022a_chip_info kx132_chip_info = {
> > > +	.name		  = "kx132-1211",
> > > +	.regmap_config	  = &kx132_regmap_config,
> > > +	.channels	  = kx132_channels,
> > > +	.num_channels	  = ARRAY_SIZE(kx132_channels),
> > > +	.fifo_length	  = KX132_FIFO_LENGTH,
> > > +	.who		  = KX132_REG_WHO,
> > > +	.id		  = KX132_ID,
> > > +	.cntl		  = KX132_REG_CNTL,
> > > +	.cntl2		  = KX132_REG_CNTL2,
> > > +	.odcntl		  = KX132_REG_ODCNTL,
> > > +	.buf_cntl1	  = KX132_REG_BUF_CNTL1,
> > > +	.buf_cntl2	  = KX132_REG_BUF_CNTL2,
> > > +	.buf_clear	  = KX132_REG_BUF_CLEAR,
> > > +	.buf_status1	  = KX132_REG_BUF_STATUS_1,
> > > +	.buf_smp_lvl_mask = KX132_MASK_BUF_SMP_LVL,  
> > 
> > There are some things in here (typically where the define isn't used
> > anywhere else) where I think it would be easier to follow if the
> > value was listed here.  Masks and IDs for example. 
> >   
> 
> After removing buf_smp_lvl_mask, which members will be easier to understand (besides id) ? 

I haven't gone through them.  Length seems an obvious one.  It's a number not a magic value.
Register addresses might also be simpler if they aren't used elsewhere.

Not really about understanding just about a define that adds nothing if all we do is
assign it to a variable of the same name.

> 
> --
> Kind Regards
> Mehdi Djait

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ