[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20230510154803.189096-1-miquel.raynal@bootlin.com>
Date: Wed, 10 May 2023 17:47:58 +0200
From: Miquel Raynal <miquel.raynal@...tlin.com>
To: Rob Herring <robh+dt@...nel.org>
Cc: Frank Rowand <frowand.list@...il.com>,
Thomas Petazzoni <thomas.petazzoni@...tlin.com>,
devicetree@...r.kernel.org, <linux-kernel@...r.kernel.org>,
linux-tegra@...r.kernel.org, dri-devel@...ts.freedesktop.org,
Thierry Reding <thierry.reding@...il.com>,
David Airlie <airlied@...il.com>,
Daniel Vetter <daniel@...ll.ch>,
Mikko Perttunen <mperttunen@...dia.com>,
Miquel Raynal <miquel.raynal@...tlin.com>
Subject: [PATCH 0/5] of: More 'device' vs. 'module' cleanups
Hello,
As part of a previous series, Rob suggested that keeping too much logic
in of/device.c was backward and would benefit from a gradual cleanup
with the hope some day to move the remaining helpers into inline
functions wrapping the proper of_*() methods.
Link: https://lore.kernel.org/lkml/CAL_JsqJE43qfYzHUuCJsbaPPBTbYX05Q7FFmPTjPFZ3Dmz_mXg@mail.gmail.com/
A few of these "conversions" happened in the series I was originally
working on. At this time I actually wrote a few other changes,
completely unrelated to my original series, but still following Rob's
cleanup idea: here they are.
Link: https://lore.kernel.org/lkml/20230307165359.225361-1-miquel.raynal@bootlin.com/
The last step of this series is to actually remove a copy of one of
these helpers which I think is not needed. This drivers/gpu/ patch
depends on the previous changes.
Thanks, Miquèl
Miquel Raynal (5):
of: module: Mutate of_device_modalias() into two helpers
of: module: Mutate of_device_uevent() into two helpers
of: module: Mutate of_device_uevent_modalias() into two helpers
of: module: Export of_uevent()
gpu: host1x: Stop open-coding of_device_uevent()
drivers/gpu/host1x/bus.c | 31 +++-----------
drivers/of/device.c | 90 ---------------------------------------
drivers/of/module.c | 82 +++++++++++++++++++++++++++++++++++
include/linux/of.h | 21 +++++++++
include/linux/of_device.h | 39 ++++++++++++++---
5 files changed, 141 insertions(+), 122 deletions(-)
--
2.34.1
Powered by blists - more mailing lists