[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20230511151919.GA7880@lst.de>
Date: Thu, 11 May 2023 17:19:19 +0200
From: Christoph Hellwig <hch@....de>
To: Yu Kuai <yukuai1@...weicloud.com>
Cc: hch@....de, tj@...nel.org, josef@...icpanda.com, axboe@...nel.dk,
yukuai3@...wei.com, cgroups@...r.kernel.org,
linux-block@...r.kernel.org, linux-kernel@...r.kernel.org,
yi.zhang@...wei.com, yangerkun@...wei.com
Subject: Re: [PATCH -next 1/6] blk-wbt: fix that wbt can't be disabled by
default
On Thu, May 11, 2023 at 09:45:04AM +0800, Yu Kuai wrote:
> @@ -730,8 +730,9 @@ void wbt_enable_default(struct gendisk *disk)
> {
> struct request_queue *q = disk->queue;
> struct rq_qos *rqos;
> - bool disable_flag = q->elevator &&
> - test_bit(ELEVATOR_FLAG_DISABLE_WBT, &q->elevator->flags);
> + bool disable_flag = (q->elevator &&
> + test_bit(ELEVATOR_FLAG_DISABLE_WBT, &q->elevator->flags)) ||
> + !IS_ENABLED(CONFIG_BLK_WBT_MQ);
Not really new in your patch, but I find the logic here very confusing.
First the disable_flag really should be enable instead, as that's how
it's actually checked, and then spelling out the conditions a bit more
would really help readability. E.g.
bool enabled = IS_ENABLED(CONFIG_BLK_WBT_MQ);
if (q->elevator &&
test_bit(ELEVATOR_FLAG_DISABLE_WBT, &q->elevator->flags))
enable = false;
Powered by blists - more mailing lists