[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <168440808427.404.1399705978286968537.tip-bot2@tip-bot2>
Date: Thu, 18 May 2023 11:08:04 -0000
From: "tip-bot2 for Jiapeng Chong" <tip-bot2@...utronix.de>
To: linux-tip-commits@...r.kernel.org
Cc: Abaci Robot <abaci@...ux.alibaba.com>,
Jiapeng Chong <jiapeng.chong@...ux.alibaba.com>,
Josh Poimboeuf <jpoimboe@...nel.org>, x86@...nel.org,
linux-kernel@...r.kernel.org
Subject: [tip: objtool/core] x86/unwind/orc: Use swap() instead of open coding it
The following commit has been merged into the objtool/core branch of tip:
Commit-ID: 95f0e3a209b0045a56a06987d85981280f523270
Gitweb: https://git.kernel.org/tip/95f0e3a209b0045a56a06987d85981280f523270
Author: Jiapeng Chong <jiapeng.chong@...ux.alibaba.com>
AuthorDate: Thu, 30 Mar 2023 10:00:14 +08:00
Committer: Josh Poimboeuf <jpoimboe@...nel.org>
CommitterDate: Tue, 16 May 2023 06:06:56 -07:00
x86/unwind/orc: Use swap() instead of open coding it
Swap is a function interface that provides exchange function. To avoid
code duplication, we can use swap function.
./arch/x86/kernel/unwind_orc.c:235:16-17: WARNING opportunity for swap().
Reported-by: Abaci Robot <abaci@...ux.alibaba.com>
Link: https://bugzilla.openanolis.cn/show_bug.cgi?id=4641
Signed-off-by: Jiapeng Chong <jiapeng.chong@...ux.alibaba.com>
Link: https://lore.kernel.org/r/20230330020014.40489-1-jiapeng.chong@linux.alibaba.com
Signed-off-by: Josh Poimboeuf <jpoimboe@...nel.org>
---
arch/x86/kernel/unwind_orc.c | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/arch/x86/kernel/unwind_orc.c b/arch/x86/kernel/unwind_orc.c
index 3ac50b7..5fbcb22 100644
--- a/arch/x86/kernel/unwind_orc.c
+++ b/arch/x86/kernel/unwind_orc.c
@@ -219,7 +219,6 @@ static struct orc_entry *cur_orc_table = __start_orc_unwind;
static void orc_sort_swap(void *_a, void *_b, int size)
{
struct orc_entry *orc_a, *orc_b;
- struct orc_entry orc_tmp;
int *a = _a, *b = _b, tmp;
int delta = _b - _a;
@@ -231,9 +230,7 @@ static void orc_sort_swap(void *_a, void *_b, int size)
/* Swap the corresponding .orc_unwind entries: */
orc_a = cur_orc_table + (a - cur_orc_ip_table);
orc_b = cur_orc_table + (b - cur_orc_ip_table);
- orc_tmp = *orc_a;
- *orc_a = *orc_b;
- *orc_b = orc_tmp;
+ swap(*orc_a, *orc_b);
}
static int orc_sort_cmp(const void *_a, const void *_b)
Powered by blists - more mailing lists