[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAK7LNAQ3KO1BY5Nq6uhHQGm_eOVNvk206A-s5pSguTO3ykLUng@mail.gmail.com>
Date: Sat, 20 May 2023 22:27:34 +0900
From: Masahiro Yamada <masahiroy@...nel.org>
To: Nick Desaulniers <ndesaulniers@...gle.com>
Cc: linux-kbuild@...r.kernel.org, linux-kernel@...r.kernel.org,
Nathan Chancellor <nathan@...nel.org>,
Nicolas Pitre <npitre@...libre.com>,
Nicolas Schier <nicolas@...sle.eu>
Subject: Re: [PATCH v5 10/21] modpost: rename find_elf_symbol() and find_elf_symbol2()
On Thu, May 18, 2023 at 6:14 AM Nick Desaulniers
<ndesaulniers@...gle.com> wrote:
>
> On Sun, May 14, 2023 at 8:28 AM Masahiro Yamada <masahiroy@...nel.org> wrote:
> >
> > find_elf_symbol() and find_elf_symbol2() are not good names.
> >
> > Rename them to find_tosym(), find_fromsym(), respectively.
>
> The comments maybe could be updated, too. The end of the comment looks
> wrong for both.
What do you mean?
Please tell me which part should be changed, and how.
> Thanks for the patch!
> Reviewed-by: Nick Desaulniers <ndesaulniers@...gle.com>
>
> >
> > Signed-off-by: Masahiro Yamada <masahiroy@...nel.org>
> > ---
> >
> > Changes in v5:
> > - Change the names
> >
> > scripts/mod/modpost.c | 12 ++++++------
> > 1 file changed, 6 insertions(+), 6 deletions(-)
> >
> > diff --git a/scripts/mod/modpost.c b/scripts/mod/modpost.c
> > index 3b7b78e69137..0d2c2aff2c03 100644
> > --- a/scripts/mod/modpost.c
> > +++ b/scripts/mod/modpost.c
> > @@ -1124,8 +1124,8 @@ static inline int is_valid_name(struct elf_info *elf, Elf_Sym *sym)
> > * In other cases the symbol needs to be looked up in the symbol table
> > * based on section and address.
> > * **/
> > -static Elf_Sym *find_elf_symbol(struct elf_info *elf, Elf64_Sword addr,
> > - Elf_Sym *relsym)
> > +static Elf_Sym *find_tosym(struct elf_info *elf, Elf64_Sword addr,
> > + Elf_Sym *relsym)
> > {
> > Elf_Sym *sym;
> > Elf_Sym *near = NULL;
> > @@ -1168,8 +1168,8 @@ static Elf_Sym *find_elf_symbol(struct elf_info *elf, Elf64_Sword addr,
> > * The ELF format may have a better way to detect what type of symbol
> > * it is, but this works for now.
> > **/
> > -static Elf_Sym *find_elf_symbol2(struct elf_info *elf, Elf_Addr addr,
> > - unsigned int secndx)
> > +static Elf_Sym *find_fromsym(struct elf_info *elf, Elf_Addr addr,
> > + unsigned int secndx)
> > {
> > Elf_Sym *sym;
> > Elf_Sym *near = NULL;
> > @@ -1207,10 +1207,10 @@ static void default_mismatch_handler(const char *modname, struct elf_info *elf,
> > const char *tosym;
> > const char *fromsym;
> >
> > - from = find_elf_symbol2(elf, r->r_offset, fsecndx);
> > + from = find_fromsym(elf, r->r_offset, fsecndx);
> > fromsym = sym_name(elf, from);
> >
> > - to = find_elf_symbol(elf, r->r_addend, sym);
> > + to = find_tosym(elf, r->r_addend, sym);
> > tosym = sym_name(elf, to);
> >
> > /* check whitelist - we may ignore it */
> > --
> > 2.39.2
> >
>
>
> --
> Thanks,
> ~Nick Desaulniers
--
Best Regards
Masahiro Yamada
Powered by blists - more mailing lists