[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <ZGzYK4x6+anak3Ew@infradead.org>
Date: Tue, 23 May 2023 08:13:47 -0700
From: Christoph Hellwig <hch@...radead.org>
To: Uladzislau Rezki <urezki@...il.com>
Cc: Christoph Hellwig <hch@...radead.org>, linux-mm@...ck.org,
Andrew Morton <akpm@...ux-foundation.org>,
LKML <linux-kernel@...r.kernel.org>, Baoquan He <bhe@...hat.com>,
Lorenzo Stoakes <lstoakes@...il.com>,
Matthew Wilcox <willy@...radead.org>,
"Liam R . Howlett" <Liam.Howlett@...cle.com>,
Dave Chinner <david@...morbit.com>,
"Paul E . McKenney" <paulmck@...nel.org>,
Joel Fernandes <joel@...lfernandes.org>,
Oleksiy Avramchenko <oleksiy.avramchenko@...y.com>
Subject: Re: [PATCH 4/9] mm: vmalloc: Add a per-CPU-zone infrastructure
On Tue, May 23, 2023 at 04:53:25PM +0200, Uladzislau Rezki wrote:
> > > +#define fbl_lock(z, i) spin_lock(&fbl(z, i, lock))
> > > +#define fbl_unlock(z, i) spin_unlock(&fbl(z, i, lock))
> >
> > Even if it is just temporary, I don't think adding these wrappers
> > make much sense.
> >
> If open-coded, it looks like:
>
> spin_lock(&z->fbl[BUSY].lock);
Give the fbl structure a name and you can have a local variable for it,
which will make all this a lot more readable. And then unless there is
a really good reason to iterate over this as an array just have three
of these structs embedded named free, busy and lazy.
Powered by blists - more mailing lists