[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <202305231026.594B2F913D@keescook>
Date: Tue, 23 May 2023 10:27:51 -0700
From: Kees Cook <keescook@...omium.org>
To: "Gustavo A. R. Silva" <gustavoars@...nel.org>
Cc: "Martin K. Petersen" <martin.petersen@...cle.com>,
"James E.J. Bottomley" <jejb@...ux.ibm.com>,
Dick Kennedy <dick.kennedy@...adcom.com>,
James Smart <james.smart@...adcom.com>,
linux-scsi@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-hardening@...r.kernel.org
Subject: Re: [PATCH 2/2][next] scsi: lpfc: Use struct_size() helper
On Tue, May 23, 2023 at 08:41:59AM -0600, Gustavo A. R. Silva wrote:
> On Wed, May 17, 2023 at 04:01:47PM -0700, Kees Cook wrote:
> > On Wed, May 17, 2023 at 03:23:01PM -0600, Gustavo A. R. Silva wrote:
> > > Prefer struct_size() over open-coded versions of idiom:
> > >
> > > sizeof(struct-with-flex-array) + sizeof(typeof-flex-array-elements) * count
> > >
> > > where count is the max number of items the flexible array is supposed to
> > > contain.
> > >
> > > Link: https://github.com/KSPP/linux/issues/160
> > > Signed-off-by: Gustavo A. R. Silva <gustavoars@...nel.org>
> > > ---
> > > drivers/scsi/lpfc/lpfc_ct.c | 6 ++----
> > > 1 file changed, 2 insertions(+), 4 deletions(-)
> > >
> > > diff --git a/drivers/scsi/lpfc/lpfc_ct.c b/drivers/scsi/lpfc/lpfc_ct.c
> > > index e880d127d7f5..3b95c56023bf 100644
> > > --- a/drivers/scsi/lpfc/lpfc_ct.c
> > > +++ b/drivers/scsi/lpfc/lpfc_ct.c
> > > @@ -3748,8 +3748,7 @@ lpfc_vmid_cmd(struct lpfc_vport *vport,
> > > rap->obj[0].entity_id_len = vmid->vmid_len;
> > > memcpy(rap->obj[0].entity_id, vmid->host_vmid, vmid->vmid_len);
> > > size = RAPP_IDENT_OFFSET +
> > > - sizeof(struct lpfc_vmid_rapp_ident_list) +
> > > - sizeof(struct entity_id_object);
> > > + struct_size(rap, obj, rap->no_of_objects);
> >
> > Has rap->no_of_objects always been "1"? (i.e. there was a prior
> > multiplication here before...
>
> Mmh.. not sure what multiplication you are talking about. I based these
> changes on the fact that rap->no_of_objects is set to cpu_to_be32(1);
> for both instances. It doesn't show up in the context of the patch, so
> here you go:
>
> 3747 rap->no_of_objects = cpu_to_be32(1);
Ah-ha! So, yeah, this patch is bad then, since no_of_objects will be a
big-endian "1".
This change:
+ struct_size(rap, obj, rap->no_of_objects);
needs to explicitly be:
+ struct_size(rap, obj, 1);
Or, alternatively, just drop the patch entirely.
--
Kees Cook
Powered by blists - more mailing lists