[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-Id: <168544082230.7583.8570017963154848959.git-patchwork-notify@kernel.org>
Date: Tue, 30 May 2023 10:00:22 +0000
From: patchwork-bot+netdevbpf@...nel.org
To: Parthiban Veerasooran <Parthiban.Veerasooran@...rochip.com>
Cc: andrew@...n.ch, hkallweit1@...il.com, linux@...linux.org.uk,
davem@...emloft.net, edumazet@...gle.com, kuba@...nel.org,
pabeni@...hat.com, netdev@...r.kernel.org,
linux-kernel@...r.kernel.org, ramon.nordin.rodriguez@...roamp.se,
horatiu.vultur@...rochip.com, Woojung.Huh@...rochip.com,
Nicolas.Ferre@...rochip.com, Thorsten.Kummermehr@...rochip.com
Subject: Re: [PATCH net-next v4 0/6] microchip_t1s: Update on Microchip 10BASE-T1S
PHY driver
Hello:
This series was applied to netdev/net-next.git (main)
by Paolo Abeni <pabeni@...hat.com>:
On Fri, 26 May 2023 20:53:42 +0530 you wrote:
> This patch series contain the below updates,
> - Fixes on the Microchip LAN8670/1/2 10BASE-T1S PHYs support in the
> net/phy/microchip_t1s.c driver.
> - Adds support for the Microchip LAN8650/1 Rev.B0 10BASE-T1S Internal
> PHYs in the net/phy/microchip_t1s.c driver.
>
> Changes:
> v2:
> - Updated cover letter contents.
> - Modified driver description is more generic as it is common for all the
> Microchip 10BASE-T1S PHYs.
> - Replaced read-modify-write code with phy_modify_mmd function.
> - Moved */ to the same line for the single line comments.
> - Changed the type int to u16 for LAN865X Rev.B0 fixup registers
> declaration.
> - Changed all the comments starting letter to upper case for the
> consistency.
> - Removed return value check of phy_read_mmd and returned directly in the
> last line of the function lan865x_revb0_indirect_read.
> - Used reverse christmas notation wherever is possible.
> - Used FIELD_PREP instead of << in all the places.
> - Used 4 byte representation for all the register addresses and values
> for consistency.
> - Comment for indirect read is modified.
> - Implemented "Reset Complete" status polling in config_init.
> - Function lan865x_setup_cfgparam is split into multiple functions for
> readability.
> - Reference to AN1760 document is added in the comment.
> - Removed interrupt disabling code as it is not needed.
> - Provided meaningful macros for the LAN865X Rev.B0 indirect read
> registers and control.
> - Replaced 0x10 with BIT(4).
> - Removed collision detection disable/enable code as it can be done with
> a separate patch later.
>
> [...]
Here is the summary with links:
- [net-next,v4,1/6] net: phy: microchip_t1s: modify driver description to be more generic
https://git.kernel.org/netdev/net-next/c/ca33db4a8602
- [net-next,v4,2/6] net: phy: microchip_t1s: replace read-modify-write code with phy_modify_mmd
https://git.kernel.org/netdev/net-next/c/221a5344806c
- [net-next,v4,3/6] net: phy: microchip_t1s: update LAN867x PHY supported revision number
https://git.kernel.org/netdev/net-next/c/6f12765ecad3
- [net-next,v4,4/6] net: phy: microchip_t1s: fix reset complete status handling
https://git.kernel.org/netdev/net-next/c/1d7650b8ce60
- [net-next,v4,5/6] net: phy: microchip_t1s: remove unnecessary interrupts disabling code
https://git.kernel.org/netdev/net-next/c/b4010beb347d
- [net-next,v4,6/6] net: phy: microchip_t1s: add support for Microchip LAN865x Rev.B0 PHYs
https://git.kernel.org/netdev/net-next/c/972c6d834633
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html
Powered by blists - more mailing lists