lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Tue, 6 Jun 2023 10:48:22 +0200
From:   Vlastimil Babka <vbabka@...e.cz>
To:     Hyeonggon Yoo <42.hyeyoo@...il.com>,
        Zhen Lei <thunder.leizhen@...wei.com>
Cc:     Christoph Lameter <cl@...ux.com>,
        Pekka Enberg <penberg@...nel.org>,
        David Rientjes <rientjes@...gle.com>,
        Joonsoo Kim <iamjoonsoo.kim@....com>,
        Andrew Morton <akpm@...ux-foundation.org>,
        Roman Gushchin <roman.gushchin@...ux.dev>, linux-mm@...ck.org,
        linux-kernel@...r.kernel.org
Subject: Re: [PATCH] mm/slab_common: reduce an if statement in create_cache()

On 6/6/23 09:48, Hyeonggon Yoo wrote:
> On Tue, Jun 06, 2023 at 02:55:43PM +0800, Zhen Lei wrote:
>> Move the 'out:' statement block out of the successful path to avoid
>> redundant check on 'err'. The value of 'err' is always zero on success
>> and negative on failure.
>> 
>> No functional changes, no performance improvements, just a little more
>> readability.
>> 
>> Signed-off-by: Zhen Lei <thunder.leizhen@...wei.com>
>> ---
>>  mm/slab_common.c | 6 ++----
>>  1 file changed, 2 insertions(+), 4 deletions(-)
>> 
>> diff --git a/mm/slab_common.c b/mm/slab_common.c
>> index 607249785c077e9..f6fe35105774944 100644
>> --- a/mm/slab_common.c
>> +++ b/mm/slab_common.c
>> @@ -236,14 +236,12 @@ static struct kmem_cache *create_cache(const char *name,
>>  
>>  	s->refcount = 1;
>>  	list_add(&s->list, &slab_caches);
>> -out:
>> -	if (err)
>> -		return ERR_PTR(err);
>>  	return s;
>>  
>>  out_free_cache:
>>  	kmem_cache_free(kmem_cache, s);
>> -	goto out;
>> +out:
>> +	return ERR_PTR(err);
>>  }
>>  
>>  /**
> 
> Hi Zhen,
> nice cleanup!
> 
> Looks correct to me,
> Reviewed-by: Hyeonggon Yoo <42.hyeyoo@...il.com>

Thanks, added to slab/for-6.5/cleanup

>> -- 
>> 2.25.1
>> 
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ