[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4fefbd7697c593b25ecc981668cc7bae1a1212d9.camel@perches.com>
Date: Sun, 18 Jun 2023 07:54:45 -0700
From: Joe Perches <joe@...ches.com>
To: Lai Jiangshan <jiangshanlai@...il.com>, tj@...nel.org,
linux-kernel@...r.kernel.org, zyhtheonly@...il.com,
zyhtheonly@...h.net
Cc: tiozhang@...iglobal.com
Subject: Re: [PATCH] workqueue: format pr_warn exceeds line length in
wq_numa_init
On Sun, 2023-06-18 at 09:19 +0800, Lai Jiangshan wrote:
> On Fri, Jun 16, 2023 at 3:00 PM tiozhang <tiozhang@...iglobal.com> wrote:
> >
> > Format this long line which would potentially let checkpatch complain
> > "WARNING: line length of 103 exceeds 100 columns".
[]
> This patch hurts the readability actually. A few extra characters exceeding
> is Okay for me.
[]
> > diff --git a/kernel/workqueue.c b/kernel/workqueue.c
[]
> > @@ -5959,7 +5959,8 @@ static void __init wq_numa_init(void)
> >
> > for_each_possible_cpu(cpu) {
> > if (WARN_ON(cpu_to_node(cpu) == NUMA_NO_NODE)) {
> > - pr_warn("workqueue: NUMA node mapping not available for cpu%d, disabling NUMA support\n", cpu);
> > + pr_warn("workqueue: NUMA node mapping not available for cpu%d, disabling NUMA support\n",
> > + cpu);
What _might_ work reasonably well is to add
#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
before any include and remove "workqueue: " from
all pr_<foo> uses.
Powered by blists - more mailing lists