[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20230619231611.2230-1-xin3.li@intel.com>
Date: Mon, 19 Jun 2023 16:16:08 -0700
From: Xin Li <xin3.li@...el.com>
To: linux-kernel@...r.kernel.org, platform-driver-x86@...r.kernel.org,
iommu@...ts.linux.dev, linux-hyperv@...r.kernel.org,
linux-perf-users@...r.kernel.org, x86@...nel.org
Cc: tglx@...utronix.de, mingo@...hat.com, bp@...en8.de,
dave.hansen@...ux.intel.com, hpa@...or.com, steve.wahl@....com,
mike.travis@....com, dimitri.sivanich@....com,
russ.anderson@....com, dvhart@...radead.org, andy@...radead.org,
joro@...tes.org, suravee.suthikulpanit@....com, will@...nel.org,
robin.murphy@....com, kys@...rosoft.com, haiyangz@...rosoft.com,
wei.liu@...nel.org, decui@...rosoft.com, dwmw2@...radead.org,
baolu.lu@...ux.intel.com, peterz@...radead.org, acme@...nel.org,
mark.rutland@....com, alexander.shishkin@...ux.intel.com,
jolsa@...nel.org, namhyung@...nel.org, irogers@...gle.com,
adrian.hunter@...el.com, xin3.li@...el.com, seanjc@...gle.com,
jiangshanlai@...il.com, jgg@...pe.ca, yangtiezhu@...ngson.cn
Subject: [PATCH 0/3] Do IRQ move cleanup with a timer instead of an IPI
No point to waste a vector for cleaning up the leftovers of a moved
interrupt. Aside of that this must be the lowest priority of all vectors
which makes FRED systems utilizing vectors 0x10-0x1f more complicated
than necessary.
Schedule a timer instead.
Thomas Gleixner (2):
x86/vector: Rename send_cleanup_vector() to vector_schedule_cleanup()
x86/vector: Replace IRQ_MOVE_CLEANUP_VECTOR with a timer callback
Xin Li (1):
tools: Get rid of IRQ_MOVE_CLEANUP_VECTOR from tools
arch/x86/include/asm/hw_irq.h | 4 +-
arch/x86/include/asm/idtentry.h | 1 -
arch/x86/include/asm/irq_vectors.h | 7 --
arch/x86/kernel/apic/vector.c | 109 ++++++++++++++----
arch/x86/kernel/idt.c | 1 -
arch/x86/platform/uv/uv_irq.c | 2 +-
drivers/iommu/amd/iommu.c | 2 +-
drivers/iommu/hyperv-iommu.c | 4 +-
drivers/iommu/intel/irq_remapping.c | 2 +-
tools/arch/x86/include/asm/irq_vectors.h | 7 --
.../beauty/tracepoints/x86_irq_vectors.sh | 2 +-
11 files changed, 92 insertions(+), 49 deletions(-)
--
2.34.1
Powered by blists - more mailing lists