[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20230626173521.459345-1-willy@infradead.org>
Date: Mon, 26 Jun 2023 18:35:09 +0100
From: "Matthew Wilcox (Oracle)" <willy@...radead.org>
To: linux-mm@...ck.org
Cc: "Matthew Wilcox (Oracle)" <willy@...radead.org>,
linux-fsdevel@...r.kernel.org, linux-kernel@...r.kernel.org,
Jan Kara <jack@...e.com>, David Howells <dhowells@...hat.com>
Subject: [PATCH 00/12] Convert write_cache_pages() to an iterator
Dave Howells doesn't like the indirect function call imposed by
write_cache_pages(), so refactor it into an iterator. I took the
opportunity to add the ability to iterate a folio_batch without having
an external variable.
This is against next-20230623. If you try to apply it on top of a tree
which doesn't include the pagevec removal series, IT WILL CRASH because
it won't reinitialise folio_batch->i and the iteration will index out
of bounds.
I have a feeling the 'done' parameter could have a better name, but I
can't think what it might be.
Matthew Wilcox (Oracle) (12):
writeback: Factor out writeback_finish()
writeback: Factor writeback_get_batch() out of write_cache_pages()
writeback: Factor should_writeback_folio() out of write_cache_pages()
writeback: Simplify the loops in write_cache_pages()
pagevec: Add ability to iterate a queue
writeback: Use the folio_batch queue iterator
writeback: Factor writeback_iter_init() out of write_cache_pages()
writeback: Factor writeback_get_folio() out of write_cache_pages()
writeback: Factor writeback_iter_next() out of write_cache_pages()
writeback: Add for_each_writeback_folio()
iomap: Convert iomap_writepages() to use for_each_writeback_folio()
writeback: Remove a use of write_cache_pages() from do_writepages()
fs/iomap/buffered-io.c | 14 +-
include/linux/pagevec.h | 18 +++
include/linux/writeback.h | 22 ++-
mm/page-writeback.c | 310 +++++++++++++++++++++-----------------
4 files changed, 216 insertions(+), 148 deletions(-)
--
2.39.2
Powered by blists - more mailing lists