[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <ZKKeQTv0ful5Ji_f@kroah.com>
Date: Mon, 3 Jul 2023 12:09:05 +0200
From: Greg KH <gregkh@...uxfoundation.org>
To: Linus Torvalds <torvalds@...ux-foundation.org>,
Andrew Morton <akpm@...ux-foundation.org>
Cc: linux-kernel@...r.kernel.org,
Stephen Rothwell <sfr@...b.auug.org.au>,
Saravana Kannan <saravanak@...gle.com>
Subject: [GIT PULL] Driver core update for 6.5-rc1
The following changes since commit 9561de3a55bed6bdd44a12820ba81ec416e705a7:
Linux 6.4-rc5 (2023-06-04 14:04:27 -0400)
are available in the Git repository at:
git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git tags/driver-core-6.5-rc1
for you to fetch changes up to a91845b9a872039618d74104c0721376ce092638:
sysfs: Skip empty folders creation (2023-06-15 13:37:53 +0200)
----------------------------------------------------------------
driver core changes for 6.5-rc1
Here are a small set of changes for 6.5-rc1 for some driver core
changes. Included in here are:
- device property cleanups to make it easier to write "agnostic"
drivers when regards to the firmware layer underneath them (DT vs.
ACPI)
- debugfs documentation updates
- devres additions
- sysfs documentation and changes to handle empty directory creation
logic better
- tiny kernfs optimizations
- other tiny changes
All of these have been in linux-next for a while with no reported
problems.
Signed-off-by: Greg Kroah-Hartman <gregkh@...uxfoundation.org>
----------------------------------------------------------------
Andy Shevchenko (3):
ACPI: Move ACPI_DEVICE_CLASS() to mod_devicetable.h
device property: Implement device_is_compatible()
ata: ahci_platform: Make code agnostic to OF/ACPI
Dave Jiang (1):
base/node: Use 'property' to identify an access parameter
Greg Kroah-Hartman (1):
Merge 6.4-rc5 into driver-core-next
Ivan Orlov (1):
debugfs: Correct the 'debugfs_create_str' docs
James Clark (4):
devres: Provide krealloc_array
hwmon: pmbus: Use devm_krealloc_array
iio: adc: Use devm_krealloc_array
serial: qcom_geni: Comment use of devm_krealloc rather than devm_krealloc_array
James Seo (1):
driver core: device.h: add some missing kerneldocs
Jesse Brandeburg (1):
MAINTAINERS: add entry for auxiliary bus
Matti Vaittinen (1):
drivers: fwnode: fix fwnode_irq_get[_byname]()
Miquel Raynal (2):
sysfs: Improve readability by following the kernel coding style
sysfs: Skip empty folders creation
Muchun Song (1):
kernfs: fix missing kernfs_idr_lock to remove an ID from the IDR
Vladislav Efanov (1):
isa: Remove unnecessary checks
Documentation/driver-api/driver-model/devres.rst | 1 +
MAINTAINERS | 10 ++
drivers/ata/ahci_platform.c | 8 +-
drivers/base/isa.c | 7 +-
drivers/base/node.c | 8 +-
drivers/base/property.c | 12 ++-
drivers/hwmon/pmbus/pmbus_core.c | 6 +-
drivers/iio/adc/xilinx-ams.c | 9 +-
drivers/iio/adc/xilinx-xadc-core.c | 17 ++--
drivers/tty/serial/qcom_geni_serial.c | 5 +
fs/debugfs/file.c | 9 --
fs/kernfs/dir.c | 2 +
fs/sysfs/group.c | 12 ++-
include/linux/acpi.h | 14 ---
include/linux/device.h | 122 ++++++++++++++++++++++-
include/linux/mod_devicetable.h | 13 +++
include/linux/property.h | 12 +++
17 files changed, 204 insertions(+), 63 deletions(-)
Powered by blists - more mailing lists