[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20230705073000.oxlb7e7sdkdxurps@pengutronix.de>
Date: Wed, 5 Jul 2023 09:30:00 +0200
From: Uwe Kleine-König <u.kleine-koenig@...gutronix.de>
To: Jonathan Cameron <Jonathan.Cameron@...wei.com>
Cc: Yangtao Li <frank.li@...o.com>,
Krzysztof Kozlowski <krzk@...nel.org>,
miquel.raynal@...tlin.com, rafael@...nel.org,
daniel.lezcano@...aro.org, amitk@...nel.org, rui.zhang@...el.com,
mmayer@...adcom.com, bcm-kernel-feedback-list@...adcom.com,
florian.fainelli@...adcom.com, tglx@...utronix.de,
matthias.bgg@...il.com, angelogioacchino.delregno@...labora.com,
bchihi@...libre.com, wenst@...omium.org, linux-pm@...r.kernel.org,
linux-kernel@...r.kernel.org, linux-arm-kernel@...ts.infradead.org,
linux-mediatek@...ts.infradead.org
Subject: Re: [PATCH v3 1/5] genirq/devres: Add
devm_request_threaded_irq_emsg()
Hello,
On Wed, Jul 05, 2023 at 10:15:37AM +0800, Jonathan Cameron wrote:
> On Tue, 4 Jul 2023 16:19:54 +0200
> Uwe Kleine-König <u.kleine-koenig@...gutronix.de> wrote:
>
> > Hello,
> >
> > On Tue, Jul 04, 2023 at 05:06:12PM +0800, Yangtao Li wrote:
> > > On 2023/7/4 16:48, Krzysztof Kozlowski wrote:
> > >
> > > > [你通常不会收到来自 krzk@...nel.org 的电子邮件。请访问 https://aka.ms/LearnAboutSenderIdentification,以了解这一点为什么很重要]
> > > >
> > > > On 03/07/2023 19:43, Uwe Kleine-König wrote:
> > > > > Hello Krzysztof,
> > > > >
> > > > > On Mon, Jul 03, 2023 at 02:31:59PM +0200, Krzysztof Kozlowski wrote:
> > > > > > On 03/07/2023 11:04, Yangtao Li wrote:
> > > > > > > There are more than 700 calls to the devm_request_threaded_irq method.
> > > > > > > Most drivers only request one interrupt resource, and these error
> > > > > > > messages are basically the same. If error messages are printed
> > > > > > > everywhere, more than 1000 lines of code can be saved by removing the
> > > > > > > msg in the driver.
> > > > > >
> > > > > > ...
> > > > > >
> > > > > > > +int devm_request_threaded_irq_emsg(struct device *dev, unsigned int irq,
> > > > > > > + irq_handler_t handler, irq_handler_t thread_fn,
> > > > > > > + unsigned long irqflags, const char *devname,
> > > > > > > + void *dev_id, const char *emsg)
> > > > > > > +{
> > > > > > > + int rc;
> > > > > > > +
> > > > > > > + rc = devm_request_threaded_irq(dev, irq, handler, NULL, irqflags,
> > > > > > > + devname, dev_id);
> > > > > > > + if (rc && rc != -EPROBE_DEFER) {
> > > > > > > + dev_err(dev, "Failed to request %sinterrupt %u %s %s: %pe\n",
> > > > > > > + thread_fn ? "threaded " : "", irq, devname ? : dev_name(dev),
> > > > > > > + emsg ? : "", ERR_PTR(rc));
> > > > > > It is open-coding dev_err_probe(). Just use dev_err_probe instead.
> > > > > dev_err_probe is supposed to be only called in probe functions, while
> > > > > devm_request_threaded_irq might be called in other contexts (e.g. when a
> > > > > device is opened). That's why I asked to not use dev_err_probe() in v2
> > > > True, but then all the callers of this function will forget to set
> > > > deferred probe reason.
> >
> > That's another reason for letting the driver issue the error message and
> > not the request_irq function.
> >
> > > So let's use dev_err_probe?
> > >
> > > BTW, any suggestions for names here, keep using
> > > devm_request_threaded_irq_emsg or change to a new name?
> >
> > I would have called it devm_request_threaded_irq_verbose() which I
> > consider easier to understand. But maybe is just my (green)
> > bikeshed.
>
> If going to use dev_err_probe() internally maybe can just use
> devm_request_threaded_irq_probe() thus reflecting that and making
> it different to the devm_request_threaded_irq()?
I like devm_request_threaded_irq_probe(), thanks for that suggestion
(even though it's red :-)
Best regards
Uwe
--
Pengutronix e.K. | Uwe Kleine-König |
Industrial Linux Solutions | https://www.pengutronix.de/ |
Download attachment "signature.asc" of type "application/pgp-signature" (489 bytes)
Powered by blists - more mailing lists